Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Unknown connection type error QsAppMetaDataConnector.exe

Hi ,

I am using the Document Analyzer v1.3 for the analysis of my Qliksense applications on the server. For this, I followed the steps as per the help document provided with the setup file.

After installing the setup, I could see the MetaData Connector folder in the similar path :

"C:\Program Files (x86)\Common Files\Qlik\Custom Data\QsAppMetadataConnector"

Also I imported the QVF file "QS Document Analyzer v1.3" from the  path:

"Documents\Qlik\Sense\Apps\ QS Document Analyzer V1.3.qvf"

After this step, I am not able to see the Edit options in the Data connection pane in the Script Editor under the folder of appmeta. Here, we select the app that we want for analysis. But I am not able to proceed further. Please see the attached file .

Request your help on this as soon as possible.

Regards,

Twinkle

4 Replies
Highlighted
Contributor III
Contributor III

Did you ever get anywhere with finding a resolution to this problem? I'm experiencing the same issue.
Highlighted
Contributor III
Contributor III

I managed to resolve this issue by copying the "QsAppMetadataConnector" folder and it's content from the default folder detailed in the support documentation:

C:\Program Files (x86)\Common Files\Qlik\Custom Data\QsAppMetadataConnector

to:

C:\Users\userid\AppData\Local\Programs\Qlik\Sense\Connectors]

Hope this helps!

Highlighted
Partner
Partner

Hi,

I ran into the same issue (Windows Server 2012 R12, Qlik Sense Enterprise Server Nov 2018), but changing the path like you did before did not work for me. Any suggestions?

Is there a way to manually import the connector? I've tried a couple of paths, but QS does not seem to see the connector.

Thanks for your help!

 

Br

 

Tibor

Highlighted
Creator
Creator

Hate to necropost but didn't see this solution on here:

Restart the server!
I tried saving to the recommended path as well:

C:\Users\[service account user ID]\AppData\Local\Programs\Qlik\Sense\Connectors

Note I used the service account (SA) user and created this folder. Not sure if this was needed, but after restarting the server the connector became available

Tried in a higher environment and all I had to do was restart the server. Working on Apr 2019 Server.