Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
QlikWorld 2020: Join us May 11 - 14, 2020 in Phoenix, AZ. Register early and save $400. Learn More
Partner
Partner

Variable in Set Analysis Not Working

Hello,

I created the following variable and used it in the set analysis expression.  The issue is that when I select a date in the Year-Month dimension, I am not getting any results as expected.  The expression is supposed to sum all payment amounts for all previous periods from the date selected in the Year-Month field.  The variable in the expression turns "active" when I remove the " "  but, the result is null.  When I include the " ", the variable turns to plain text and the result is 0.00.  I tested the results of the variable to the values in the Year-Month field and they match (i.e. 2018-Jun to 2018-Jun).  I know I'm close but don't see where I'm not correct.

Thank you in advance for any assistance!!

Variable: vYearMonth = GetFieldSelections([Year-Month])

Sum({$<Year=,Month=, [Year-Month]={"<$(vYearMonth)"}>}PaymentAmount)

3 Replies
Partner
Partner

Re: Variable in Set Analysis Not Working

it needs to be "" because its a search (the less than < part)

How is your variable defined? is it defined as =GetFieldSelections([Year-Month]) or without the = sign.

if latter use $(=[Year-Month]) in the set analysis

Whats the type of your Year month column?

Partner
Partner

Re: Variable in Set Analysis Not Working

Hi Dilip,

See attached variable script defined and the type for the Year-Month field. Also, I agree the " " are required.  Still not sure why it's not working. 

Partner
Partner

Re: Variable in Set Analysis Not Working

did you try $(= in the set analysis? Your variable definition does not have an = so i would

use $(=vMonthYear)