Qlik Community

Qlik Sense Cloud Discussions

Highlighted
olivercollinsc
New Contributor II

Problem with formula in Qlikcloud

Hello,

I'm new in Qlikcommunity and I have a problem with a formula. It's work in Qlik Sense Desktop but when I upload to QlikCloud the Data appears in 0. What could be the problem? if someone can help me please.

This is the formula, is a Measure. I need to count the customer (CLIENTE) of the last month.

Count({$<T_DIA=,T_AÑO, T_MES, FECHA = {"$(='>=' & Date(MonthStart(Max(FECHA), -1)) & '<=' & Date(MonthEnd(Max(FECHA), -1)))"}, VT_EMPRESA={'DAS'}>}distinct CLIENTE)

Thankful in advance


Oliver

Tags (1)
1 Solution

Accepted Solutions
Employee
Employee

Re: Problem with formula in Qlikcloud

Try this formula;

Count({$<T_DIA=,T_ANO, T_MES, FECHA = {"$(='>=' & Date(MonthStart(Max(FECHA), -1),'YYYY-MM-DD') & '<=' & Date(MonthEnd(Max(FECHA), -1),'YYYY-MM-DD'))"}, VT_EMPRESA={'DAS'}>}distinct CLIENTE)formula.png

7 Replies
Employee
Employee

Re: Problem with formula in Qlikcloud

Hi Oliver - welcome and thanks for joining. I will attempt to look at this now - but some of our other great members might also assist and may get back to you before I do.

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Regards,

Michael Tarallo

Qlik

Regards,
Mike Tarallo
Qlik
Employee
Employee

Re: Problem with formula in Qlikcloud

OK taking a deeper look - this is is simple Set Analysis with dollar expansion $(=   this should work in both versions no matter - I am suspect of the field names, in particular  the Nya (~) or the date field (year) - T_AÑO - name may be different once uploaded to Qlik Sense cloud. Can you check all the field names - and also create a new sheet with a new chart not using Set Analysis and just those fields. Let's see how they are represented in Qlik Sense Cloud.

Let me know.

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.

Regards,

Michael Tarallo

Qlik

Regards,
Mike Tarallo
Qlik
Employee
Employee

Re: Problem with formula in Qlikcloud

Hi,

Does Your data have comma (or dot) as decimal delimiter?

If You look at Your data model in Data Model Viewer, are the fields used in the expression recognized as numeric/timestamp or ascii?

BR

Lucke

olivercollinsc
New Contributor II

Re: Problem with formula in Qlikcloud

Hi Michael. Thank you for the response. I change T_AÑO to T_ANO but doesn't work, still showing the data in 0 and also I try to not use Set Analysis but doesn't work either.

I'm attached the project. Can you check it please?

The formula is in the sheets "Test" and "Supervisor", column Cli. Mes Ant.

Thankful in advance

olivercollinsc
New Contributor II

Re: Problem with formula in Qlikcloud

Hi Lucke. Thank you for the response. In my computer the decimal delimiter are (dot).

Employee
Employee

Re: Problem with formula in Qlikcloud

Try this formula;

Count({$<T_DIA=,T_ANO, T_MES, FECHA = {"$(='>=' & Date(MonthStart(Max(FECHA), -1),'YYYY-MM-DD') & '<=' & Date(MonthEnd(Max(FECHA), -1),'YYYY-MM-DD'))"}, VT_EMPRESA={'DAS'}>}distinct CLIENTE)formula.png

olivercollinsc
New Contributor II

Re: Problem with formula in Qlikcloud

With this formula works. Thank you very much.