Qlik Community

Qlik Sense Data Connectivity

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Qlik Analytics Tour 2020 Online. Begins August 10th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

Data connections are not loading when creating new apps in Qliksense Desktop

Hi Guys,

I installed Feb 2019 version of Qliksense desktop client and created connection and application based on it. So far so good. Now I tried creating new app and wanted to utilize existing connection, the data connection shows blank. It spins for couple of seconds and doesn't return previously created connections. Strangely if I duplicate the previous app where I created the connection, I could see the them loaded. 

Connection1.PNGConnection2.PNG

I tried running a repair, with no success. Has anybody faced this issue? Please advice.

Thanks,

Kavya

1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Re: Data connections are not loading when creating new apps in Qliksense Desktop

Hi Kavya

In Qlik Sense Desktop, Data Connections are saved in the app when you create them. That is why they are not in new apps, however they are duplicated with the app when an app is duplicated. Following on this, that is why you "import" them into the QMC with the app on a server deployment.

In other words, what you are experiencing is normal.

Have a look at the very bottom of this help page:

https://help.qlik.com/en-US/sense/February2019/Subsystems/Hub/Content/Sense_Hub/LoadData/connect-dat...

Regards,

Mauritz

View solution in original post

5 Replies
Highlighted
Partner
Partner

Re: Data connections are not loading when creating new apps in Qliksense Desktop

Hi Kavya

In Qlik Sense Desktop, Data Connections are saved in the app when you create them. That is why they are not in new apps, however they are duplicated with the app when an app is duplicated. Following on this, that is why you "import" them into the QMC with the app on a server deployment.

In other words, what you are experiencing is normal.

Have a look at the very bottom of this help page:

https://help.qlik.com/en-US/sense/February2019/Subsystems/Hub/Content/Sense_Hub/LoadData/connect-dat...

Regards,

Mauritz

View solution in original post

Highlighted
Partner
Partner

Re: Data connections are not loading when creating new apps in Qliksense Desktop

Hi,
Data connections are specific to the app where you created them unless you assign properties to make them available through out. And so you won't see any existing connection in the new app created by you.
Highlighted
Contributor II
Contributor II

Re: Data connections are not loading when creating new apps in Qliksense Desktop

Thanks for the response. So if I am not using server deployment and using desktop version only, duplicating apps is the only solution to utilize existing data connections?

 

Highlighted
MVP
MVP

Re: Data connections are not loading when creating new apps in Qliksense Desktop

In Qliksense desktop, each app is a complete unit and has no knowledge of any other apps. Connections are an app level property, so even if you use the same name and data source, changing the connection in one app has no impact on the "same" connection in another app.

In QlikSense server, connections are shared and can be managed and permissioned in QMC. Changes to a connection will affect all apps using that connection.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Highlighted
Partner
Partner

Re: Data connections are not loading when creating new apps in Qliksense Desktop

That's correct @KavyaV Smiley Wink. What @jontydkpi said sums it up pretty well.