Qlik Community

Qlik Sense Data Connectivity

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Not applicable

How can I delete, then add a new data file?

In QLIK Sense desktop, I think I am deleting a file by clicking on the trashcan in the data manager view, then I add my new file, which is in the same format, but has updated records. The problem is the old file "rawbase as of 5-23-17" still looks like it is loaded and not deleted (see red circles). My new desired file "Raw4QLIK_Aug_17" is listed also (see green circle). Now I don't know what is loaded, as they both have the same structure. I'm expecting to see only Raw4QLIK_Aug_17 and don't know why Rawbase as of 5-23-17 still shows.  Can you give me some guidance? Thanks, Jerry AlexanderMarked file view.jpg

2 Replies

Re: How can I delete, then add a new data file?

Hi Jerry,

it looks like you misunderstand the process of the data load. When you add a file in the Data Manager, you make this file "known" to Qlik Sense. Its definitions become available. The actual data is being loaded after you click on "Load Data".

Similarly, when you delete a file from the Data Manager and add another file, no data is being loaded until you actually click on "Load Data". At that time, the internal data set is cleared and the new table is being loaded.

I'd also suggest to revisit the approach to refreshing your data. If you delete the old fine and add the new file just to bring in fresh data, you could do it a lot simpler if you named your files identically, and then simply reload your data (by clicking on "Load Data") when you have new data in the same file. This way, you don't need to delete and add files every time you have fresh data.


Oleg Troyansky

Upgrade your Qlik skills with my book QlikView Your Business: An Expert Guide to Business Discovery with QlikView and Qlik Sense

Not applicable

Re: How can I delete, then add a new data file?


Thank you for your help. I played with this for hours—with a fair amount of frustration. I began to realize that what I thought was the name of an old file was actually the name of the table. So, I tried and tried and tried to change the name of the table (because it looked like the name of a file (Rawbase as of 5-23-17) but I didn’t find how to change it. There must be a way to change it (table name), but I haven’t found the way.


Community Browser