Qlik Community

Qlik Sense Data Connectivity

Discussion board where members can learn more about Qlik Sense Data Connectivity.

denis_neto
New Contributor II

REST Connector 1.1 Authentication Error

Hi, I already created a discussion about this error, but I had no answer. New June 2017 REST Connector error

I have successfully connected to web servers using Qlik Sense Desktop 3.2 and using Postman, but using the Qlik Sense Jun/Set 2017 returns error.

For example, using REST connector, I set:

In the older versions I just set Authentication "No".

Now, I receive "Connection to server failed".

I tried all types of authentication schema and three different web services, but every time I get the same error.

Has anyone issues with the new REST connector 1.1? Is it a bug?

Thank you.

3 Replies
felipedl
Valued Contributor III

Re: REST Connector 1.1 Authentication Error

Hi Denis,

Try setting up a basic REST connection to this API with Get option, no need to change any parameters:

https://jsonplaceholder.typicode.com/posts

If this works, it's a problem with the API your using, giving you the error message probably due to credential errors or so.

By the way, i'm testing it using the latest September patch and there's no 1.1 REST Connector version (I assume its a typo) the last connector version on official Qlik site is 1.0.

Hope it helps,

Felipe.

denis_neto
New Contributor II

Re: REST Connector 1.1 Authentication Error

Hi Felip, thanks for your reply.

I tried to connect to your suggested API and I got the same error.

I set "Anonymous" and "Basic" with empty user/password fields.

One of the upgrades of Jun 2017 version is this new REST connector, see this "help" link: https://help.qlik.com/en-US/connectors/Subsystems/REST_connector_help/Content/1.1/Create-REST-connec...

I don't know what to do, this is very strange. Maybe is the "server certificate validation" or the "Trusted Locations", I have no idea. I tried to see the logs, but it was not helpful.

Thanks again.

felipedl
Valued Contributor III

Re: REST Connector 1.1 Authentication Error

That's weird,

I have the September patch

Sample.png

And don't have the REST connector version you got

Sample2.png

For the connection you tried, I only created a new REST connection and pasted the URL, haven't changed a thin.

Could be a bug, but since i dont have the same version as you, I can't test it.

Felipe.

Community Browser