Qlik Community

Qlik Sense Data Connectivity

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Not applicable

Trouble loading certain columns via OLEDB connection

Hello - I'm having trouble loading all columns that have headers which contain spaces via an OLEDB connection.

I can see all of the columns and check them off in the data manager prior to loading:data manager view.png

However, upon loading I can only see a select number of the columns (16 out of the 37 checked):

data model viewer.png

Yet, the data load editor displays all 37 of the selected columns:

data load editor.png

While troubleshooting we noticed that the columns that didn't get loaded had a space in their name (Filter Predicate, Passing Fraction etc.).

When trying to load only one of the columns which has a space in it, we receive the following error:Error.png

Does anyone have any insight to this? We don't think it's an issue with the actual connection since we can view and load most of the columns that don't meet the "having a space" condition. Are there any known issues surrounding this? Any feedback is much appreciated. Also let me know if there's any other information that you need me to clarify. Thanks!

4 Replies

Re: Trouble loading certain columns via OLEDB connection

Your database-driver might not completely suitable for loading these table. But before playing with them and/or searching for alternative drivers I would try to replace the double-quotes as field-delimiter. Double-quotes work very well within qlik but some databases and drivers didn't accept them. Therefore make a copy from your sql-statement, comment in then out and replace within the copy the double-quotes with grave accents and try it again. If this didn't work look in the help from the database/driver how they handle quotes. For qlik there is a very fine posting about it: QlikView Quoteology.

- Marcus

Not applicable

Re: Trouble loading certain columns via OLEDB connection

Hi Marcus,

Thank you for the reply. We've tried replacing the double quotes with grave accents but unfortunately that did not work either. We're working with the provider of the driver to see if there is anything that can be done to append column headers so they do not have spaces. However we have tried using an OLEDB connection from excel with the same driver and were able to return all expected columns. I can post a screenshot too if you'd like.

Re: Trouble loading certain columns via OLEDB connection

What happens if you load: SQL Select * From ...? If it worked it could be handled as a workaround and you could drop the unneeded fields afterwards per: drop fields field1, field2 ....;

- Marcus

Highlighted
Not applicable

Re: Trouble loading certain columns via OLEDB connection

Hi Marcus,

The SQL Select* From solution worked! I'm guessing it may just be an issue with the load script editor not being able to read column headers with spaces in them from an OLEDB connection query, but we still have to test that with a different driver connection in order to validate. Thanks for your help on this!