Qlik Community

Qlik Sense Data Connectivity

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Not applicable

qliksense hub oledb provider for sql server not connecting

I am trying to connect to an sql server that is on a separate machine. I am getting a ping reply from that machine but when I try to create a new connection on qliksense hub, it fails

I am assuming that it is because the hub is using a different port than what we opened for our database server

Is there any way to tell the hub to use some specific ports for connecting to the sql server?

Which ports is it using by default by the way?

Arif

14 Replies
Not applicable

Re: qliksense hub oledb provider for sql server not connecting

Hi,

Each and every settings of all ports and proxies are available in proxy services section of QMC. So you can check or change the settings from there only.

Regards,

Brijesh.

Re: qliksense hub oledb provider for sql server not connecting

Normally you need only access to ports 1433 and 1434. It's possible to specify the port in the connection string. "Provider=SQLOLEDB;Data Source=oursqlserver.ourdomain,1433; Initial Catalog=ABC"

Perhaps this article helps: SQL Server TCP and UDP Ports | SQL Server content from SQL Server Pro


talk is cheap, supply exceeds demand
Not applicable

Re: qliksense hub oledb provider for sql server not connecting

Ok I am still having problem. So I have two machines on the same network. One machine has sql server installed and the other one has the qliksense hub. I have full access to the sql server and its databases. Also, when I try to ping the sql server machine from qliksense hub machine, I also get a ping reply

However, when I try to create an oledb provider for sql server connection and use windows integrated security, it does not work. When I try to click on create connection, I get an error that you do not have access to this datasource

Can you please help me fix this.

Regards

Syed

Re: qliksense hub oledb provider for sql server not connecting

Does the service account that you use for Qlik Sense also have access to the database? Perhaps you should ask your local friendly database administrator for help troubleshooting this.


talk is cheap, supply exceeds demand
Not applicable

Re: qliksense hub oledb provider for sql server not connecting

Yes, I have full access to the database. When I use sql server management studio, I can do all the queries on the database. According to the db guy, 59061,59104,53374 are the ports open/used by the database. I tried these ports in the connection string but could not get them working

yocaqlikview
New Contributor II

Re: qliksense hub oledb provider for sql server not connecting

Hi,

we have the same issue.

we are able to connect to SQL Server vía ODBC but we are not able to create the connection from qliksense hub

do you have any advice for this issue?

thanks in advance

mqaiser1
New Contributor

Re: qliksense hub oledb provider for sql server not connecting

It could be you dont have permission on your apps. give additional access in qlik sense qmc app section so that you can create connection. if you have steam, give stream additional access.

If thats all good, then please ping your db server first. if thats correct, check user security in database server.

You are using windows integrated security, you both Qlik server and database server must be on same domain or trusted domain.

Thanks

Qaiser

ma258827
New Contributor II

Re: qliksense hub oledb provider for sql server not connecting

Hi Gysbert,

I have to setup MS OLE DB provider for Analysis Services 11.0, but i don't see it on my OLE DB list of connectors.

do i need to install it explicitly.


if yes, could you please share the links and related docs..


Thanks, Manish

jerrysvensson
Valued Contributor II

Re: qliksense hub oledb provider for sql server not connecting

I have the same problem. Although test connection says OK, which I found out doesn't mean a thing.

When I press Load and then try to Select database, the list is empty. Very strange.

The service account does not have access to the database. But my account has.

OLE DB Problem, no database in Select database...

Community Browser