Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Not applicable

Corporate network - problem with port 4244

Hi,

We are starting to use QlikSense for our customers and did a successful install however we immediately hit a wall: port 4244 being used for windows authentication. On a corporate network they are hesitant (or unwilling) to open this port for outbound communications.

How can we work our way around this? When I look around on the web I can find info about non-windows authentication but this is not the way we want to go (using LDAP). I also find info on reverse proxy's but it is not clear to me whether this would solve the issue.

Thanks for any help!

Edwin

6 Replies
kuczynska
Contributor III

Re: Corporate network - problem with port 4244

Hi Edwin,

We are hitting a very similar issue - don't think we will get the port open too for corporate security reasons. Could you advise how did you progress on your end? We also have to follow non-Windows authentication here. Any advice would be appreciated.

Thanks in advance,

Michalina

Employee
Employee

Re: Corporate network - problem with port 4244

You can use the custom authentication and write your authentication module to authenticate against the AD or LDAP.

kuczynska
Contributor III

Re: Corporate network - problem with port 4244

Hi,

thanks for your reply but this is not the case here as all of our users are external. QMC doesn't allow setting both https ports to 443 (shows the message 'All ports in this property group must be unique on the same proxy'). We will probably end up setting up a reversed proxy on Apache etc.

barry_stevens
Contributor II

Re: Corporate network - problem with port 4244

Can't you define the port to use - ie not 4244? - on the proxies window

kuczynska
Contributor III

Re: Corporate network - problem with port 4244

Unfortunately not - this would mean we have to change the port for all of our customers and require their corporate networks to open new port, which not everyone wants to do.

We end up adding a custom authorization module to our scope to resolve this.

Thanks,

Not applicable

Re: Corporate network - problem with port 4244

Hi,

We've implemented a proxy in front of the QlikSense server based on a 'officially not supported' solution from the Qlik Community. Here's a link: Reverse Proxy using Apache but we use NGINX, this is also documented in the community: Re: Reverse Proxy and Authentication port redirect

Hope this helps...

Cheers,

Edwin

Community Browser