Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

gdevarashettyhf
New Contributor III

EDX Command Line trigger not working

*****************************************************  NOTE *******************************************************************************************

I posted this in wrong forum looks like. Updated the thread to Deployment forum. Also attached a word document that tells how to do but I am not able to find the QVCertTool.zip file. Anyone knows where can I find the zip file please. THANK YOU. Ganesh

*****************************************************  NOTE ******************************************************************************************

I am using command line EDX run. did the following.

1. Created a QMC Task with EDX trigger and password

2. Copied the EDX command program onto a machine (even on server).

3. executing below in cmd (admin mode)

   qmsedx -task="ABC.qvw" -qms="http://PUB:4799/QMS/Service"  -password=Password123 -verbosity=3

4. Get below error message followed by an exception trace:

Failed to create a client to the specified Uri.

The request channel timed out while waiting for a reply after 00:00:59.8979898.

Increase the timeout value passed to the call to Request or increase the SendTim

eout value on the Binding. The time allotted to this operation may have been a p

ortion of a longer timeout.

5. If I give https://PUB:4799/QMS/Service  (https instead of http), the following error comes up

Failed to create a client to the specified Uri.
The provided URI scheme 'https' is invalid; expected 'http'.
Parameter name: via

Unhandled Exception: System.ArgumentException: The provided URI scheme 'https' i
s invalid; expected 'http'.

6. If enter http://PUB:4799/QMS/Service URL in browser, there is no response (timeout). If I enter https://PUB:4799/QMS/Service  URL in browser, a certificate message shows up but webpage opens up.

Any help is greatly appreciated.

Thank you,

Ganesh

Message was edited by: Ganesh Devarashetty Added a Word Document that lists how to do it. But I am not able to find the QVCertTool.zip file. Anyone knows where can I find the zip file please. THANK YOU. Ganesh

Tags (1)
4 Replies
gdevarashettyhf
New Contributor III

Re: EDX Command Line trigger not working

Just checking if anyone? One thing I am thinking is the QMS port number is the same for both HTTP and HTTPS. Is that an issue? Is that the reason that HTTPS works but HTTP does not?

Appreciate any insight.

cleite2014
New Contributor III

Re: EDX Command Line trigger not working

Hi Ganesh,

Did you get the EDX Command Line Trigger working? I am beginning to look at this at my company and am looking for a complete beginning to end setup process to accomplish this task.

Any help would be greatly appreciated.

Thank you,

Craig Leite

gdevarashettyhf
New Contributor III

Re: EDX Command Line trigger not working

Hi Craig, Good for you. No I still haven't solved this issue. But I feel my issue is mainly due to the use of certificates. If you are not using certificates, you can make this work using a simple BATCH file setup, available in the forums.

URL - Using EDX in QlikView 11

Ganesh

Employee
Employee

Re: EDX Command Line trigger not working

Hi Ganish,

Try qmsedx -task="ABC.qvw" -qms= PUB  -password=Password123 -verbosity=3

Also, the task ID is  "Task Name" not the abc.qvw

Bill

Community Browser