Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Error Installing 2.2.4 server in Windows 2012 R2 64-bit x64

Hi guys,

i am encountering a number of errors, and have tried everything written on this forum to fix it - without any success.

Errors:

- Proxy service will not start

- Scheduler service will not stop

- From event viewer i get an error on the .Net framework, although 4.5.2 is installed, the error is this:

.NET Runtime version : 4.0.30319.34014 - This application could not be started.This application requires one of the following versions of the .NET Framework:

.NETFramework,Version=v4.5.2


I believe all this is related to the .NET framework as qlik sense somehow believes 4.0.3 is installed, although the server feature view clearly show 4.5 being installed. Also, when downloading 4.5 .NET framework, it gives me the options "Repair 4.5.2 to original state" and "Remove 4.5.2 from this computer"... So Windows can see the 4.5.2, but Sense cannot??

I have tried the following:

- Re-install Qlik Sense Server

- Re-install .NET framework

- The "hack" with making service timeout go from 30 seconds as default to 10 minutes instead

... and a number of smaller things i have forgotten by now, as i am currently debugging on the 5th hour..

Any advice?

THANKS!

11 Replies
Highlighted
Contributor III
Contributor III

Hi Rene,

I've running it on a test server 2012 R2 with .Net 4.6.1

It was an upgrade from 2.2.3.

Perhaps you can verify your .Net setup.

https://blogs.msdn.microsoft.com/astebner/2008/10/13/net-framework-setup-verification-tool-users-gui...

Highlighted
Partner
Partner

Sometimes you may need to change some time out settings in the registry, Help desk can give you appropriate numbers for your configuration.DWORD Value should be get changed for the services communication. 

Highlighted
Not applicable

.NET 4.5.2 is verified .

the time out settings has been changed without any change.

Just performed a new clean re-install, and the Proxy Service is not started. When i try to uninstall again, i cannot because i cannot manually stop the scheduler service - get error 1061 - (only by terminating the scheduler.exe from "details" in task mgr and disabling the automatic startup , can i stop the scheduler service).

What can i do to ensure i make a complete, clean uninstall? Any files i should manually remove? Would it help to install 2.1.1 instead perhaps? could .NET 4.6.1 make a difference?

The current proces for uninstall:

1. Enter Task Mgr,

2. Enter "Services"

3. Enter Properties of all Qlik Services and disable automatic startup

4. Enter "Details" in task mgr and stop all ".exe" files related to the sense services

5. Enter Sense.Exe and choose "uninstall"

The end - removal of folders/certificates etc. i am missing, to get "a fresh start" ?

Thanks

Highlighted
Contributor III
Contributor III

‌Just out of curiosity I cleaned my test system en did a clean install of 2.2.4. It installed flawless.

So I'm puzzled why it's not installing in your enviroment....

This is my configuration:

2 W2k12 R2 servers, one AD controller, one member server. Both fully updated. .Net 4.6.1.

I've run the installation with a own service account with local admin right.

Highlighted
Partner
Partner

Steps are good. Make sure you have domain admin service account which has all the access.

Highlighted
Not applicable

I am not the admin on the server (and neither very knowledgeable on this topic): What exactly should the Service Account be, regarding authorization and rights? Usually this is not a problem, as it is just an admin of some sort, but is there a specific set of rights it should have? a specific "type" of admin?

Thanks.

Highlighted
Contributor III
Contributor III

‌Hi Rene,

The service account has to have local admin rights. So it has to be member of the local group Administrators.

If the user you are using to install doesn't have this rights and the service account hasn't either that is probably causing your installation problems.

If you follow the installation guide these requirement are mentioned.

Highlighted
Not applicable

Everything seems to be in order then - and all other services except the proxy is running smoothly by the service account. It really beats me, why it wont install properly and run the proxy service

Highlighted
Partner
Partner

If your service account is not local administrator you will get error similar to the these.

I would make sure that the account you are using to run the services actually is local admin on the server.

Logon to the server using your service account and try to run an elevated command prompt.