Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

mickael_weqan
New Contributor III

Error on 4242 and no postgresql table

Hi Community,

I've got an issue on installing Qlik Sense Server, I tried 2.x and 3.x  :

After installing, all qlik services are up,

services.png

but I've got a white page when I launch hub or QMC.

I've got some errors on 4242 and 4444 ports when I checks logs :

Web exception when contacting service uri https://localhost:4242/

Unable to connect to the remote server -> No connection could be made because the target machine actively refused it 127.0.0.1:4242

I tried to change manually used port, but on pstgreSQL, I don't see any qlik table.

postgrsql.png

I didn’t have any firewall blocking these ports.

Do you have any clue ? I tried several installs, reboot and nothing change on 4242 port state.

Why I don't see any table in postgrSQL?

Thanks for your help,

Mickael.

1 Solution

Accepted Solutions
mickael_weqan
New Contributor III

Re: Error on 4242 and no postgresql table

Case solved by Qlik support.

This is a Microsoft .NET Framework issue.

The .NET Framework creates an extra " <DbProviderFactories />" line under the System.data.

Manually delete the extra line.

To modify the .Net Framework64 to address the issue, perform the following steps in order:

1- Browse to  "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config

2- Using Notepad or similar editor, open "machine.config" (create a copy of this file prior to modifying)

3- Find the following section :

  <system.data>

    <DbProviderFactories>

      <add name=" .... "

   </DbProviderFactories>

<DbProviderFactories />  (If this line is present, REMOVE it as noted in Step 4)

  </system.data>

User-added image

4- Remove the additional "<DbProviderFactories />" line

5- Save the file.

Thanks Qlik support!

2 Replies
Employee
Employee

Re: Error on 4242 and no postgresql table

Hi Mickael,

seems your server is listening on IPV6 port [::1] whereas the web exception you've reported is referencing to the IPV4.

Try to put EnableIPv6Support=0 in the Settings.ini file

Remember to leave a blank line at the end

mickael_weqan
New Contributor III

Re: Error on 4242 and no postgresql table

Case solved by Qlik support.

This is a Microsoft .NET Framework issue.

The .NET Framework creates an extra " <DbProviderFactories />" line under the System.data.

Manually delete the extra line.

To modify the .Net Framework64 to address the issue, perform the following steps in order:

1- Browse to  "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config

2- Using Notepad or similar editor, open "machine.config" (create a copy of this file prior to modifying)

3- Find the following section :

  <system.data>

    <DbProviderFactories>

      <add name=" .... "

   </DbProviderFactories>

<DbProviderFactories />  (If this line is present, REMOVE it as noted in Step 4)

  </system.data>

User-added image

4- Remove the additional "<DbProviderFactories />" line

5- Save the file.

Thanks Qlik support!

Community Browser