Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

See why Qlik is recognized as a Leader for the 10th year in a row – and discover how Qlik can help put your business in the lead. Get Report
New Contributor

Fresh installation of RIM node - Qlik Sense November 2017 Patch 2

Hi there,

I have a problem, namely for some time we are running on QS 3.1 and now we decided - time to move on... so let's install a fresh QS Nov'2017 Patch2 and I thought that finally we could make use of another machine and use it for Development. So:
-  Server_1 - Production
- Server_2- Development
My idea is to have a Production link like this: http://<server>/hub and another link for developers http://<server>/dev/hub - and my understanding is that while developing they will consume the resources from Server_2 whereas Server_1 will be only for Published apps for business users.

I installed and configured a central node (Server_1)- I enabled HTTP; I've checked whether it works... everything seems to be ok. Then I installed a RIM node  (Server_2) - I have provided the details for the Shared DB... installation went smoothly. No issues. Next step, following the instruction on qlik help & youtube videos recorded by Qlik...https://help.qlik.com/en-

Qlik Sense Architecture - YouTube

I added a new node ,with all the certification... no problems faced. I selected the services (initially i tried with a proxy - i thought that since on version 3.1 this service actually fails quite often, therefore maybe having it separate could be beneficial, however I already tried also without Proxy). Going forward I also enabled HTTP on the additional Node. I have added a Virtual Proxy with 'dev' prefix (+Suffix to the cookie). I added a Load Balancing for the dev node. I set the purpose of the Sever_1 to Production and Server_2 to Development... and the problem is that when I'm trying to reach on the development link it gives me HTTP 404

For the time being the Firewall is OFF on both machines - just to make sure these are not the ports which makes fool of me.

I would be grateful if you could help me resolve this. Maybe my assumption is wrong and I actually cannot accomplish what I intend to, however I also read quite a few threads, nevertheless I could not address mine problem...

QlikSense: Dev to Test to Prod

2 Nodes Servers Environment - do i need Proxy Service for Central and Rim Node?

Multi-Node: App could not be found

I would be really grateful for any kind of help or suggestion

Thanks in advance