Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

yheehong8
New Contributor

HTTP Error 404 after enabling the HTTP connection

Hi,

I completed a qliksense server installation and able to access to qmc using HTTPS (https://localhost/qmc). After logon and applied the license, I navigated to CONFIGURE SYSTEM->Proxies->Central Node to turn on the Allow HTTP. I restarted all the QlikSense services and try to access using HTTP (http://localhost/qmc). The following error is displayed. Please advise how to fix the HTTP 404 error.


Http404.png

14 Replies
awhitfield
Esteemed Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Hee,

so is port 80 available for Qliksense to use OR is an other app / process using it? E>G. IIS?

Andy

yheehong8
New Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Andy,

I do not think there is any other app using port 80. Other than netstat command, is there any other command allows me to find out ? Please advise.

See below the output with the netstat command executed on the QlikSense server.

Http404_II.png

awhitfield
Esteemed Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Hee,

where are you actually access from? On the server itself OR remotely?

try (http://servername/qmc). instead.

Andy

yheehong8
New Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Andy,

The previous two output is from the access on the server itself.

Please find below the output done using (http://10.1.1.10/qmc)

1) From a notebook

Http404_III.png

2) On the server

Http404_IV.png

awhitfield
Esteemed Contributor

Re: HTTP Error 404 after enabling the HTTP connection

You could download and use:

TCPView for Windows - Windows Sysinternals | Microsoft Docs

It will show if something else, e.g. IIS is using local port http

Give it a go

Andy

yheehong8
New Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Andy,

I cannot find any process using Local Port HTTP nor 80 except the System (See below - 1st two rows). Is there any other detail I need to look for ? Please advise.

TCPView_1.png

awhitfield
Esteemed Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Hee,,

so if system is listening on it then it's been used!! You have SQl installed so maybe you have SSRS too!.

You should change the default http in the proxy to say 81, and try that, you need to specify the new port in the url too.

Andy

yheehong8
New Contributor

Re: HTTP Error 404 after enabling the HTTP connection

Hi Andy,

It is not advisible to remove the system from listening to port 80. Correct me if I am wrong.

Is it possible to have Qlik Sense to co-exist with system to listen to port 80 or is there any workaround besides changing the default proxy with port 80? 

kaanerisen
Contributor III

Re: HTTP Error 404 after enabling the HTTP connection

Hi Hee,

Go to QMC and changed http port to an available one like 81.

Proxies ‒ Qlik Sense

You can go to QMC over https url even you checked to "allow http" option.

Community Browser