Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

agigliotti
Honored Contributor II

Issues after upgrading qlik sense to version 3.0

Hello,

I'm facing problems after upgrading customer's qlik sense multi-node site from version 2.2.4 to version 3.0.

I upgraded successfully both the central node first and the rim node after.

It ended with no errors in both server.

Now either the QMC and Hub doesn't works anymore in both nodes.

Before upgrading the central node I made a backup of repository using repositorySnapshotManager (RSM) utility.

Calling the hub I get the following error message:

"An error occurred. The load balancing module did not return any engine service for the following app: __hub"

Someone can help me ???

However I submitted a new case to the support portal.

Many thanks in advance.

Best Regards

Andrea

Tags (1)
1 Solution

Accepted Solutions
agigliotti
Honored Contributor II

Re: Issues after upgrading qlik sense to version 3.0

Yes finally I solved opening the port 4900 (two-ways) on the firewall and disabling IPv6 in TCP settings.

17 Replies
korsikov
Valued Contributor II

Re: Issues after upgrading qlik sense to version 3.0

do you upgrade all node correct? with DB cleanup before instalation progress?

agigliotti
Honored Contributor II

Re: Issues after upgrading qlik sense to version 3.0

yes starting with the central node.

what do you means as DB cleanup ?

korsikov
Valued Contributor II

Re: Issues after upgrading qlik sense to version 3.0

then you upgraded without clearing the database. This is a big problem. It is necessary to carefully read the documentation for each version.

In file QlikSense30ReleaseNotes.pdf page 14

Perform a database cleaning before migrating to 3.0
It is recommended that customers with large amount of users or applications performs a database
cleaning before migrating from 2.0.x to 3.0.
After performing an upgrade in a multi-node environment, it can take very long time for newly created
database items (such as sheets, applications, bookmarks, or tags) to appear on all nodes. This is caused
by long synchronization queues between the nodes, as a result of the upgrade. All new items will be at
the end of these queues. From Sense 2.2 the repository database is stored in RAM to improve the
performance, for users with very large databases the database can become larger than the available
RAM on the server which results in an error during startup. If you are running a large installation (users or
apps) we recommend that you perform the steps described below before performing the upgrade.
Workaround: Synchronization queues will eventually finalize by themselves, but in very large
environments this can take several hours. If you import a large Active Directory, it is recommended to do
the following before upgrade to reduce upgrade synchronization queues:
 Make sure that you applied best practices for User Directory connectors:
https://community.qlik.com/docs/DOC-14708
 If a large Active Directory has been imported without filters, do the following:
1. Setup LDAP import filters, according to the best practice guide, to reduce size of
imported user attributes.
2. Remove users and perform a new import of the Active Directory.
3. Run the Database Cleanup Script, provided by Qlik, to clean the repository database
before upgrading. To acquire the Database Cleanup Script, log in to the Support Portal
and search for article “17620”. The title of the article is “Qlik Sense Database Cleanup
Script 2.2.x”.
4. Restart the system and start the upgrade.

mountaindude
Contributor III

Re: Issues after upgrading qlik sense to version 3.0

+1 for doing repository cleanup before upgrading.

When doing this on previous updates, it turned out there were all sorts of weird stuff in the repository, that could be removed. We did not benchmark the system pre and post the cleanup, but it did feel snappier after tidying the repository db.

On the other hand, what's causing all this mess (broken foreign keys are kind of bad...)?

I would hope Qlik are taking steps to improve things, so these issues don't appear to begin with..

korsikov
Valued Contributor II

Re: Issues after upgrading qlik sense to version 3.0

agigliotti
Honored Contributor II

Re: Issues after upgrading qlik sense to version 3.0

yes it's running on both node central and rim.

I read that thread but this is a different kind of problem because it's affects only the RIM node HUB.

agigliotti
Honored Contributor II

Re: Issues after upgrading qlik sense to version 3.0

Qlik support told me that it's a bug of version 3.0 and it's already fixed in the coming version 3.0.1 that it will be released today.

I really hope so, it will ?

Many Thanks.

Andrea

Highlighted
knithesh
New Contributor III

Re: Issues after upgrading qlik sense to version 3.0

Hi Andrea,

Did you run DB cleanup script followed by check app status & removes app status scripts prior to upgradeprovided by Qlik support? This would definitely help.

I had to revert back my upgrade and run these scripts and did the upgrade again. It worked fine without any issues.

I heard from Qlik support that they found loading and sync issue and coming up with 3.0.1. This was supposed to be release last Friday (07/22), but this date was moved to next Monday.

Hope this helps!!

Thanks,

Nithesh

agigliotti
Honored Contributor II

Re: Issues after upgrading qlik sense to version 3.0

You heard version 3.0.1 will be released today or on August 1 ?