Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

sravan2013
New Contributor II

Issues with Feb2019 Qlik version

Hello experts,

I upgraded to Qliksense 2019 February version and all of a sudden, it is taking way too long to source the data from oracle database. Surprisingly if the same QVF file is used by other team member  (and with same load script & connections) in the same office, it is loading in less than 10 mins   for them whereas on my laptop it is taking close to 3 hours. 

Following are the different actions taken but no luck

  1. Got confirmation from DBA that nothing was changed on the database side. Ruled out anything with database
  2. Replaced my laptop with brand new one with more powerful one. So laptop was not the problem.
  3. Reinstalled qliksense and tried in different ways ( i created a new qlik account and downloaded using that new id as well)

Nothing worked and I still have the performance problem. Can someone help me on what needs to be done to address this performance issue. Thank you all!

 

Labels (1)
3 Replies
passionate
Valued Contributor

Re: Issues with Feb2019 Qlik version

try to install previous version of qliksense and check if it's working as before.

just to be sure that this is qliksense issue

Employee
Employee

Re: Issues with Feb2019 Qlik version

For data load performance concerns you need to find a way to isolate what part of the data extraction is consuming the time.

Qlik Sense creates a search index by default at the end of reload. This will take significant time of you have large and complex data set. It should not take 3 hours, but I would suggest you disable it to exclude it as a factor, or to confirm how much time is spend on the indexing. Add the belwo variable to your script in Main section;

SET CreateSearchIndexOnReload=0;

Time and effort is mostly spend on data source and in network during extraction. To isolate how on the actual extraction is, I would suggest that your script only execute the SQL query and retrieve data from source. Meaning, that you comment out any Qlik Sense load statement, which are the Qlik Sense side of processing. This will tell you the time it takes to execute the SQL query on, including query time network transfer and loading data into memory.

What connector are you using? Qlik ODBC connector, Oracle ODBC, Oracle OLEDB or something else?
If you have only tried on connection, a good way to troubleshoot is to create an alternative connection to allow comparing performance. This will also enable you to conclude if the issue is somehow related to a specific driver.

You mention "same QVF file ". Does this mean that you and your colleague use Qlik Sense desktop clients? If yes, are you all using Feb 2019 for the reload, or is your colleague still on previous release?
For Qlik Sense Enterprise, I would expect the same server side reload to execute identically.
sravan2013
New Contributor II

Re: Issues with Feb2019 Qlik version

Thanks for your reply!

Yes I already have "SET CreateSearchIndexOnReload=0;" in my load script and I connected to Oracle database using Qlik Oracle connector (which is available in the list of database connections)

Yes we all got updated to Qlik Feb 2019 version and since then I am having problem but none of them have any issues. I shared the QVF file which i used with them and tried refreshing using their Qliksense desktop version and it got loaded in less than 8 mins whereas for me I had to abort after waiting for 50+ mins.