Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

long5hot
New Contributor III

LocalMachineUsers Connector corrupted after upgrade to 3.2 SR5

Back in November we upgraded from 2.2 to the above version. We didn't realise there was a problem at the time, as we didn't have to add new users & we've been full-on busy with other matters ... but now we've discovered that this User Directory Connector seems to have become corrupted by the upgrade. It hasn't successfully synced since prior to the upgrade, and clicking Edit on the connector shows the following...

Capture.PNG

We haven't been able to find any mention of this problem or trouble-shooting steps to take, and obviously it's critical we find a fix.

We're going to attempt to delete and re-create the connector (if QMC provides the option!) on a temporary cloned server, but I thought I should ask the question here in case anyone has any suggestions. Any ideas at all would be greatly appreciated.

Edit: Deleting the connector is not a solution, as QMC does not provide a way to create it again. I've also tried running the Repair option in the installer, both on a machine with the deleted connector & another with the connector still in place, but it had no effect. I'd have to wonder why Qlik would let you delete such an essential item and provide no way to add it again, or repair it with the installer?

So it looks like, if we want to add new users (which we need to), we have no choice but to start with a fresh install on a different machine, transfer all the apps across & setup all the data connections, users and tasks.  Only problem with that is our users need the bookmarks they've created, they're not just an optional convenience, and a reinstall will lose those bookmarks which is unacceptable.

Can anyone suggest any way out of this predicament?

1 Solution

Accepted Solutions
dmackenna
New Contributor II

Re: LocalMachineUsers Connector corrupted after upgrade to 3.2 SR5

The "Local Network" User Directory option has been removed in Sense v3.2.5 . Users added via the Windows "Local Users and Groups" method are automatically added to the user list in the QMC, once that user attempts to log in. A token must be assigned at this point, in order for the user to successfully log in. See here for the community discussion I am getting my info from:

https://community.qlik.com/thread/259901

1 Reply
dmackenna
New Contributor II

Re: LocalMachineUsers Connector corrupted after upgrade to 3.2 SR5

The "Local Network" User Directory option has been removed in Sense v3.2.5 . Users added via the Windows "Local Users and Groups" method are automatically added to the user list in the QMC, once that user attempts to log in. A token must be assigned at this point, in order for the user to successfully log in. See here for the community discussion I am getting my info from:

https://community.qlik.com/thread/259901

Community Browser