Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
josecardenas
New Contributor III

Monitoring Apps 2.0.1 fail on reload - missing fields

Hi Tyler

I've updated qlik sense to 2.0.1 and I've found an error reloading license and operations monitor

On License monitor I'm getting field not found - <CounterName>

On operations monitor I'm getting Field not found - <ProxySessionId>

Please check the scripts logs downloaded

Thanks

Jose

26 Replies
Employee
Employee

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Jose - This is a known issue with the timing of when certain logs are written after a service or machine restart. A fix has been identified but will not be available until the next service release.

The workaround for now is to remove the malformed log files mentioned in the data load logs, specifically:

lib://ServerLogFolder/Engine\Audit\ANALYTICSSERVER_AuditActivity_Engine.txt

and

lib://ServerLogFolder/Engine\Audit\ANALYTICSSERVER_QixCounter_Engine.txt

where ServerLogFolder is the folder where the primary Log files are stored (default is c:\programdata\qlik\sense\log)

fosuzuki
Valued Contributor II

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Hi Tyler,

I also had trouble reloading the monitors. I removed the files you mentioned, but the reload tasks found errors with other 32 files in the lib://ArchivedLogsFolder folders:

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Audit\[SERVERNAME]_AuditActivity_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Audit\[SERVERNAME]_QixCounter_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\System\[SERVERNAME]_Service_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Trace\[SERVERNAME]_Performance_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Trace\[SERVERNAME]_Session_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Trace\[SERVERNAME]_System_Engine_[DATETIME].log

- lib://ArchivedLogsFolder/[USERLOGIN]\Engine\Trace\[SERVERNAME]_Traffic_Engine_[DATETIME].log

Apparently this bug affected all the archived logs generated between the update to v2.0.1 and the fix you mentioned for the ServerLogFolder...


Employee
Employee

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Fernando,

Unfortunately, the bug we are discussing (that you are experiencing) will show itself anytime services are restarted. So, if you have multiple service restarts, it is possible that a malformed log will be created which will cause the apps to fail in reload.

The next SR will have the fix to this logging, but those bad logs will still need to be removed even after the fix.

The next version of the Monitoring Apps will handle these malformed logs better (i.e. not fail on reload!) but the delivery date for updated apps has not been defined yet.

If this is becoming impossible to deal with and you cannot wait for the SR, you can modify the load script and include SET errormode=0; before the few load .... from statements in both apps.  Duplicate the apps, open the copies in the Hub and make the changes, and then published those apps to the monitoring apps stream (can replace the existing apps).  This is far from ideal and would not be 'supported', but it pains me to think of your inability to use the apps

fosuzuki
Valued Contributor II

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Hello Tyler,

I am from a partner and I've encountered this problem in my test environment, so fortunately for me this won't be such a big deal.

The next SR you are talking about is the one expected to be released in September?

I really appreciate your comments. For me it's ok, but it will sure help other people with Prod environments and a real need to use the monitoring apps.

josecardenas
New Contributor III

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

 

Hi Taylor

 

I've removed the "malformed" files including historical ones and it is working. Many thanks for the guidance. However, I am getting a new error, very uncommon, by the way, Field not found - <Id_temp> in the license monitor app.  It's happening when the sub contacttables is called for "LogContent" as  concatToTable and "Working" as IncrementalTable; the contactField is getting an error when the sub is creating the $(concatField)_temp

 

Please, see the log attached

Many thanks for your answer,

ose

Employee
Employee

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Hola Jose -

I have seen this reload error but it is usually just when I have either turned off all Qlik services and reload the app two times (no new log entry has been generated) or when I copy log folders to a local drive for testing and then reload the app twice.  The reason is that there is not a single new log entry to be found and the load script does not handle that situation well.

The next release of the Monitoring apps will include a few updates to the load script to handle this and other unexpected situations with the logs.

Can you tell me - when are you seeing this reload error? Just reloading the app from QMC? Or in a duplicate app or other scenario?

Employee
Employee

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Fernando - Yes, the next service release 2.0.2 includes a fix to the logs to prevent these malformed logs. I am not sure when this SR is planned for release, though I would guess in the next few weeks.

Also, as I shared with Jose, the next release of the apps (not in the 2.0.2 service release) will handle reload issues in a more robust manner. Again it is not clear to me when 2.1 will be released.

josecardenas
New Contributor III

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Hola Tyler,

 

The reload error was after I've deleted the malformed files, and I have to restart the services for a proxy change. The reloading task shows me the error sent.  I’ve just decided stop the task, disable for a while and then enable it and run it again. Right now is working scheduled without a problem!

Gracias,

Jose

Employee
Employee

Re: Monitoring Apps 2.0.1 fail on reload - missing fields

Look for the 2.0.2 release in the next week or so!