Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

zahidrahim_ocp
Contributor

QMC is not working after successful installation

Dear Experts,

We have successfully installed and using Qlik Test Server. Now on a separate machine we have installed QLIK Production Server after complete successful installation QMC page is not appearing neither on Production Machine itself nor from clients.

Clients are seeing error message:

This site can’t be reached

On Server using the URL: https://qlik/qmc/

This page can’t be displayed

After clicking Fix Connection Problems, We saw error:

The remote device or resource won't accept the connection          Detected

We have tried both url: https://qlik/qmc/ https://localhost/qmc/

Best Regards,

Zahid Rahim

17 Replies
shraddha_g
Honored Contributor III

Re: QMC is not working after successful installation

did you check QlikSense Services? all the services are running?

also check any error in Logs

zahidrahim_ocp
Contributor

Re: QMC is not working after successful installation

Yes, All services are running perfectly even after restart.

Further can you please guide me to the log location as i could not find any logs.

shraddha_g
Honored Contributor III

Re: QMC is not working after successful installation

Logs at ProgramData/Qlik/Sense/Logs

zahidrahim_ocp
Contributor

Re: QMC is not working after successful installation

Below are the few last lines from proxy\logs

360 20180117T132605.297+0500 ERROR QLIK System.Proxy.Proxy.Communication.Rest.ProxyRestClient 12 b7cb33da-4421-4b77-8b6c-59deb0995403 QLIK\Qservice When contacting https://localhost:4242/ No connection could be made because the target machine actively refused it 127.0.0.1:4242↵↓Unable to connect to the remote server    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)↵↓   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)↵↓   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)↵↓   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)↵↓   at Qlik.Sense.Common.Communication.REST.Client.WebClientEx.GetWebResponse(WebRequest request, IAsyncResult result)↵↓   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result) b7cb33da-4421-4b77-8b6c-59deb0995403

361 20180117T132605.297+0500 WARN QLIK System.Proxy.Proxy.Settings.SettingsHandler 9 5df44c80-912f-4942-8e73-bfd318df5596 QLIK\Qservice Could not contact local repository to retrieve proxy service settings No connection could be made because the target machine actively refused it 127.0.0.1:4242↵↓Unable to connect to the remote server    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)↵↓   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)↵↓   at Proxy.Communication.Rest.ProxyRestClient.CallSync[TR](String restCommand, RESTMethod method, Object jsonObject, IDictionary`2 additionalHeaders)↵↓   at Proxy.Communication.Rest.QrsRestClient.GetLocalProxyService()↵↓   at Proxy.Settings.SettingsHandler.TryRetrieveSettingsFor(Func`1 call, String resourceName) 5df44c80-912f-4942-8e73-bfd318df5596

362 20180117T132612.333+0500 ERROR QLIK System.Proxy.Proxy.Communication.Rest.ProxyRestClient 16 d9b06b4f-39ed-4cab-8ece-4d2df430e6eb QLIK\Qservice When contacting https://localhost:4242/ No connection could be made because the target machine actively refused it 127.0.0.1:4242↵↓Unable to connect to the remote server    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)↵↓   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)↵↓   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)↵↓   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)↵↓   at Qlik.Sense.Common.Communication.REST.Client.WebClientEx.GetWebResponse(WebRequest request, IAsyncResult result)↵↓   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result) d9b06b4f-39ed-4cab-8ece-4d2df430e6eb

363 20180117T132612.333+0500 WARN QLIK System.Proxy.Proxy.Settings.SettingsHandler 7 ccff8bf2-68d0-4565-8be1-ffd5783d8520 QLIK\Qservice Could not contact local repository to retrieve local server node configuration No connection could be made because the target machine actively refused it 127.0.0.1:4242↵↓Unable to connect to the remote server    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)↵↓   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)↵↓   at Proxy.Communication.Rest.ProxyRestClient.CallSync(String restCommand, RESTMethod method, Object jsonObject, IDictionary`2 additionalHeaders)↵↓   at Proxy.Communication.Rest.QrsRestClient.GetLocalServerNodeConfiguration()↵↓   at Proxy.Settings.SettingsHandler.TryRetrieveSettingsFor(Func`1 call, String resourceName) ccff8bf2-68d0-4565-8be1-ffd5783d8520

siddharth_s3
Contributor

Re: QMC is not working after successful installation

Is it only QMC? Can you open the hub?

zahidrahim_ocp
Contributor

Re: QMC is not working after successful installation

BOTH, HUB also giving same issue.

siddharth_s3
Contributor

Re: QMC is not working after successful installation

Did it ever work?

Did you make any changes to the proxy settings?

If you are using a proxy, make sure the "bypass proxy server for local address" option is checked.

It might be that the QPS is trying to use the regular way and your internet works differently.

Capture.PNG

zahidrahim_ocp
Contributor

Re: QMC is not working after successful installation

No it never worked after the installation.

I have disabled the proxy server and also matched the setting with my other running server.

siddharth_s3
Contributor

Re: QMC is not working after successful installation

Did you change the proxy settings now? If so, try restarting the Qlik services.

Otherwise, do you have IIS or skype installed on the server?

Try this in CMD: This will check which service is running on which port.

C:/> netstat -anob >%USERPROFILE%\ports.txt

C:/> start %USERPROFILE%\ports.txt

The above 2 commands will open a .txt file.

Check which "PID" is listening to port 443. Then open task manager and go to "Details" sections. Find the PID which is listening on port 443.

If it is anything other than QlikSense proxy service, there is your problem.

Community Browser