Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

chadwickleung
New Contributor III

QMC session is forced to end after changed to "Always anonymous user"

Hi there,

The Authentication (anonymous access mode) of the Central Proxy was accidentally changed to "Always anonymous user" and now the resources link in QMC cannot be accessed, every time any resource link is clicked an error of "Your session is ended" (attached) is returned. The Qlik Sense Proxy Service and other QS services are all at the status "started".

How can the access mode be restored to the default value?

Thanks

Chadwick

Tags (1)
7 Replies
Not applicable

Re: QMC session is forced to end after changed to "Always anonymous user"

Same problem here.

I tried to make the hub accessible via the internet and according to one post, i should set that value to "Always anonymous user".

Now I get that error on 127.0.0.1/qmc.

Could you find a solution?

If not, is it possible to reset everything to its default values?

chadwickleung
New Contributor III

Re: QMC session is forced to end after changed to "Always anonymous user"

I finally found a workaround by restoring the value of the Anonymous access mode at DB level (PostgreSQL).

1) Execute the pgAdmin program (path ..\Qlik\Sense\Repository\PostgreSQL\9.3\bin\pgAdmin3.exe) and connect to the DB. Refer to the attached image, the password is the one input during QS server installation

2) Locate the table "VituralProxyConfigs". For my case, the table is under [QlikSenseDB] -> [Databases] -> [QSR] -> [Schemas] -> [public] -> [Tables] -> [VirtualProxyConfigs].

DB Connection.JPG

3) When you view the data in the table, refer to the column [AnonymoseAccessMode] the value for the "Central Proxy (Default)" row. To restore to the option a (as below), update the value from 2 to 0.

     a) No anonymous user [0]

     b) Allow anonymous user [1]

     c) Always anonymous user [2]

Hope this help.

Not applicable

Re: QMC session is forced to end after changed to "Always anonymous user"

I am also facing the same error! Does anyone have a workaround to get into QMC to reverse the change?

Or a way to change the config files back to "no anonymous user" ?

Thanks,

Ariane

Not applicable

Re: QMC session is forced to end after changed to "Always anonymous user"

FYI I have resolved this. You need to stop all Qlik services,

then log into the database and edit the ProxyConfig table - change the value of anonymous user from 2 to 0.

agsnasoft
New Contributor III

Re: QMC session is forced to end after changed to "Always anonymous user"

Hello everyone

I'm going through the same problem they had, I mark the same error and I can no longer access Sense QMC. Try searching for pgAdmin.exe but I can not find that .exe in the path I specify Chadwick Leung.

The second step I do not understand how it is done.

Ariane Gadd I do not understand how to follow the steps you took to solve the problem, you could help me please or tell me where I need to go.

is that I'm just using QlikSense Server and I'm still not familiar with the Server

Thank you

I hope you can help me

chadwickleung
New Contributor III

Re: QMC session is forced to end after changed to "Always anonymous user"

Hi Julio,

The mentioned pgAdmin3.exe path refers to the Qlik Sense 3.2.x installation. If you have Jun 2017 (or later) Release installed, the pgadmin program is not bundled. You need to download and install it yourself, the binary can be found from pdadmin.org site. I forgot which versions I had problem to make a connection, the version 4 v1.1 has worked fine.


The default path of the pgadmin installation is

"C:\Program Files (x86)\pgAdmin 4\v1\runtime\pgAdmin4.exe"


After you started the pgadmin4 program, create a new "server" connection according to the properties of your environment (as the step 2 shown and follow the steps to locate the VirtualProxyConfigs table for an update.


Hope this help. Good Luck


Chadwick

ismhaelveran
New Contributor

Re: QMC session is forced to end after changed to "Always anonymous user"

Hi Julio,

We had the same problem. We can't find the pgAdmin3.exe so what we did, we downloaded it from the internet. Run it after installation. Next problem, we can't find the centralproxyconfig. So what we did, we run an sql query to find it and update the anonymoususer from 2 to 0.

anonymoususer.png

Community Browser