Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

QRS error: Connector is not responding

Hi all,

I have installed Qlik Sense 3.2 SR 2 to a Windows 2016 server.

Receive the following errors for Monitor application tasks.

Due to policy issues connection to internet from the server is blocked.

Could someone please help me to solve this issue?

Operations Monitor:

2017-03-29 18:22:42 1768 CALL QRS

2017-03-29 18:22:42 1769

2017-03-29 18:22:42 0799 LET NumRowsQRS = 0

2017-03-29 18:22:42 0802 For each endpoint in 'qrs_user','qrs_app','qrs_appobject','qrs_task'

2017-03-29 18:22:42 0803

2017-03-29 18:22:42 0803 CALL qrs_user

2017-03-29 18:22:42 0804

2017-03-29 18:22:42 0825 LIB CONNECT TO ***

2017-03-29 18:23:12      Error: Connector is not responding

2017-03-29 18:23:12      Execution Failed

2017-03-29 18:23:12      Execution finished.

 

License Monitor: 

2017-03-29 18:22:27 1044 CALL QRS

2017-03-29 18:22:27 1045

2017-03-29 18:22:27 0457 LET NumRowsQRS = 0

2017-03-29 18:22:27 0458 SET QRS_RowCounts = 'QRS Row Counts: '

2017-03-29 18:22:27 0460 For each endpoint in 'qrs_userAccess','qrs_loginAccess','qrs_user','qrs_licenseSummary','qrs_stream'

2017-03-29 18:22:27 0461

2017-03-29 18:22:27 0461 CALL qrs_userAccess

2017-03-29 18:22:27 0462 

2017-03-29 18:22:27 0482 LIB CONNECT TO ***

2017-03-29 18:22:57      Error: Connector is not responding

2017-03-29 18:22:57      Execution finished.

 

QMC: Data Connections:

qrs_user

sa_repository (INTERNAL\sa_repository)

CUSTOM CONNECT TO "provider=QvRestConnector.exe;

url=https://localhost/qrs/user/full;

 

Thank you in advance for any assistance!

1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Option 1(Recommend): Editing the Connector configuration file:Stop all Qlik Sense services on all nodes
1. Open the config file in the connector folder in C:\Program Files\Common
Files\Qlik\Custom Data\
for instance C:\Program Files\Common Files\Qlik\Custom
Data\QvOdbcConnectorPackage\QvOdbcConnectorPackage.exe.config
2. Add the following values before the closing </configuration> tag:

<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>


3. Repeat steps 2 and 3 for all nodes and all .config files
C:\Program Files\Common Files\Qlik\Custom
Data\QvOdbcConnectorPackage\QvOdbcConnectorPackage.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvDataMarketConnector\QvDataMarketConnector.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvSalesforceConnector\QvSalesforceConnector.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvRestConnector\QvRestConnector.exe.config
Option 2: Editing the .Net Framework's machine.config file
1. Edit C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config
a) If there is a <runtime/> tag, change it to

<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>


b) If there is other stuff in the <runtime> section, then change it to look like this:

<runtime>
<some other="stuff">
<...>
<generatePublisherEvidence enabled="false"/>
</runtime>


2. Save machine.config
3. Repeat on all nodes (if applicable)

View solution in original post

10 Replies
Highlighted
Employee
Employee

be sure the user you're using for the installation and the user set to run the Qlik services is local Admin

Partner
Partner

Hi Vincenzo,

thanks for your response.

Installation was made with same "MasterUser" crendentials that is running the Qlik Sense services

(with one excemption. Qlik Sense Repository Database is run by Local System).

This MasterUser is set as RootAdmin in QMC.

Also set in Computer Management --> Administrators and in Qlik Sense Service Users Groups

After setup had problems to get the services running.

This was fixed by changing ServicesPipeTimeout setting in Registry Editor to two minutes.

I receive the following error (twice) when accessing Load Editor for a test app.

After this shows the standard log folders on the right.

Any other ideas to check?

LoadEditor_errorinfo.jpg

Highlighted
Creator II
Creator II

Is this a multi-node environment? What happens if you change the data connection url to node name.

url=https://localhost/qrs/user/full;

url=https://fullyqualifiedservername/qrs/user/full;

Highlighted
Partner
Partner

Hi Jai,

This is Single Node environment.

I modified the Data connection string for qrs_uers and qrs_userAccess connections

by replacing localhost with fullserver name and then restarted all Qlik sense services.

Reloaded tasks for both monitors. No changes, still same error.

sa_repository user I have given RootAdmin rights,

so gave RootAdmin access rights for sa_scheduler as well.

Based on Log files reload is executed by sa_scheduler...but still, no changes.

"Reload Executed By            UserDirectory=INTERNAL; UserId=sa_scheduler"

Highlighted
Partner
Partner

Hi,

According to Qlik Sense 3.2 Help software is compatible with Windows 2016 server.

Has anyone made such installation successfully?

Highlighted
Partner
Partner

Could you please follow to C:\ProgramData\Qlik\Custom Data\QvRestConnector\Log

There we'll have more informations about this issues.

Check this folder C:\Program Files\Common Files\Qlik\Custom Data make sure all Connectors Files it's there.

This issue may be associated with Windows UAC.

And check if your server has internet access as suggested here:

License Monitor and Operations Reload Error

Highlighted
Partner
Partner

Hey there,

I faced the same issue this morning upgrading to QS 3.2.3.

I hope you have already solved it, otherwise you can find the solution in this post: Connectors not responding

Cheers

Highlighted
Partner
Partner

Try to use a Microsoft Loopback Adapter

Install Microsoft Loopback Adapter

Highlighted
Partner
Partner

Option 1(Recommend): Editing the Connector configuration file:Stop all Qlik Sense services on all nodes
1. Open the config file in the connector folder in C:\Program Files\Common
Files\Qlik\Custom Data\
for instance C:\Program Files\Common Files\Qlik\Custom
Data\QvOdbcConnectorPackage\QvOdbcConnectorPackage.exe.config
2. Add the following values before the closing </configuration> tag:

<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>


3. Repeat steps 2 and 3 for all nodes and all .config files
C:\Program Files\Common Files\Qlik\Custom
Data\QvOdbcConnectorPackage\QvOdbcConnectorPackage.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvDataMarketConnector\QvDataMarketConnector.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvSalesforceConnector\QvSalesforceConnector.exe.config
C:\Program Files\Common Files\Qlik\Custom
Data\QvRestConnector\QvRestConnector.exe.config
Option 2: Editing the .Net Framework's machine.config file
1. Edit C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config
a) If there is a <runtime/> tag, change it to

<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>


b) If there is other stuff in the <runtime> section, then change it to look like this:

<runtime>
<some other="stuff">
<...>
<generatePublisherEvidence enabled="false"/>
</runtime>


2. Save machine.config
3. Repeat on all nodes (if applicable)

View solution in original post