Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
See why BI users voted Qlik #1 in 11 categories. GET REPORT
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Qlik Sense Configuration with an NSX Load Balancer

I have a client running 3 Proxy/Engine nodes and 3 Scheduler nodes.

I had originally set up 1 proxy/Engine + 2 Engine + 3 Scheduler Nodes. 

We decided the "single point of failure" risk with a single proxy node was a poor risk. so we added proxies to the engine nodes and then set up a load balancer. They Elected to use a VMware NSX Load balancer.

 

We are getting 400 errors and cannot get things working.

We've opened just about every port you can think of.

 

Any suggestions for options would be appreciated.

 

Thanks

1 Solution

Accepted Solutions
Highlighted
Partner
Partner

We found our problem, and I must admit I should have caught it.

 

We did not have anything in the "Load balancing module base URI" field. Once we added our system's freindly URL to that field the load balancer had no issues.

View solution in original post

4 Replies
Highlighted
Partner
Partner

We found our problem, and I must admit I should have caught it.

 

We did not have anything in the "Load balancing module base URI" field. Once we added our system's freindly URL to that field the load balancer had no issues.

View solution in original post

Highlighted
Employee
Employee

Hey, Chris.

maybe you can get me the config post?

Employee
Employee

Hi @chriscammers 

Can you send a screenshot of the setup in QMC as I have the exact same issue but can't understand why putting the Load Balancer URI has fixed it as that's for LB between proxies and engines...

 

Thanks in advance

Highlighted
Employee
Employee

Hi,

So following this post https://support.qlik.com/articles/000044284 to use the /qps/user endpoint, we had to configure in the 'Extension' box of the Service monitor in the NSX with the following string (FQDNThatIsWhitelisted is the name of the service you are looking to step such as loadbalncer.bobbob.com:

header=Host:FQDNThatIsWhitelisted -H FQDNThatIsWhitelisted –sni

Once this was done there were no more errors in the logs and the health worked....

No need for anything in the Load Balencer URI in Virtual Proxies.

Hope this helps