Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Qlik Sense Data Manager - Stuck at loading tables

Hi,

We are facing a couple of weird issue with Qlik Sense server. We had a running application, and out of no where one day we found out that the Data Manager was not showing any table. When we go to Data Load editor, the script is present in the Auto generated script, but vanishes after a few seconds. And this thing happens everytime we open the data load editor for that application. The data in app was present with all the transformation we've applied in the data manager.

So we copied the script and added a new custom script and pasted the auto generated one in that, opened the data manager and synchronize the tables to view the model in Data manager. Since then everything was working fine. Today, when I wanted to change something in the model, I opened the Data manager and it keeps on saying "Loading tables". But nothing happens.

We can't find anything in the logs and are not sure what can we do to resolve this.

Thanks

9 Replies
Highlighted
Contributor II
Contributor II

Hi everyone, I'm having similar problems. My page has been stuck on 'loading tables' for 20 minutes now, while the changes I made to the script aren't that much. What's going on when this happens? What can we do?

Highlighted
Contributor II
Contributor II

Same here! I have waited a very long time (30+ mins) to wait for scripted tables to be synchronized in Data Manager.

In addition, even when I don't need to synchronize the scripted tables, I am always waiting for Data Manager to display the tables and this happens in both Desktop and Enterprise Server environment... it is really painful and a big productivity killer.

Highlighted
Contributor III
Contributor III

One tip I have for other users who are experiencing this issue: put a LIMIT statement on all your data tables to keep them to <~100 rows and reload the app. It seems that when you dramatically reduce the size of the data tables in question it *can* speed up the load time in the DM. However, if you have complicated queries built into your load script they may still need some time to execute even in a limited fashion before the page can be prepared. 

I've had similar problems with the DM since we installed. I don't think we're observing a bug, I think this is just the expected (and unacceptable) speed of the system that generates this page. It's easily the most frustrating part of Qlik Sense, and I hope the community managers pay attention to these posts and talk to product about it. 

It frequently takes far longer than the time required to execute the load statement to get this page to load, synchronization frequently takes even longer, and sometimes after a sync the system will simply never actually load the DM page and just gets stuck with the loading icon. You have to wait until you see the table at the bottom of the page pop up in grey in the background, which appears to indicate that synchronization is complete, and then reload the page. (And wait for the manager to load again, ugh)

Highlighted
Contributor II
Contributor II

Having the same issue, it's getting really frustrating to have efficiency so heavily impacted by this. 

Highlighted
Contributor
Contributor

Also having this issue. I'm still very new to Qlik, is there another way to perform data cleanup than the data manager or am I dependent on the resolution of the bug to proceed? 

thanks! 

Highlighted
Contributor III
Contributor III

I think you need to check on Security Rules to allows user can still access the folder and prepare data

Thanks 

Highlighted
Contributor II
Contributor II

Hi everyone,

 

i m facing the same issue, besides i could no more load data from my sql server in the data loader, this is only possible from qmc

error.png

 

any ideas please ?? 

Thanks

Highlighted
Contributor
Contributor

I am getting 'incomplete data visualization' in data manager. This happened when I added a calculated field in data manager. When I click on edit table in data manager, no table data appears. Only 'incomplete data visualization' appears. What is the solution for this?

Highlighted
Contributor III
Contributor III

Hi @rups, it sounds like perhaps there was an error when the Data Manager attempted to compose the code which would have generated your calculated column. 

You could try heading over to the Data Load Editor page, navigating to the "Auto-Generated Section" of the code, unlocking it, deleting the section entirely, and then heading back to the Data Manager page. This should delete the calculated column you added and cause the data manager to believe the tables are in need of synchronization, allowing you to rebuild the auto-generated section of the script. 

If the issue happens again when you try to define the same column, it may be that you've got an error in the column expression or perhaps have located a bug.