Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

sth_wch004
New Contributor III

Qlik Sense Desktop - Installation Failed

Dear Community,

Tried the following solutions but no luck. Please help

Installation failed.PNG

Operating system: Window 7 64-bit

1) installation package and select "Run as Administrator "

2) Change registry etry.

2.1. Open regedit

2.2. Seach for HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User

Shell Folders

2.3. Change the path in "Personal" entry to a local path, but remember the

old path!

2.4. Now you can install qlikview without an error.

2.5. Change the path in "Personal" to your old.

1 Reply
susanspring
New Contributor

Re: Qlik Sense Desktop - Installation Failed

I have this happening as well and am stuck.  I also tried to  change 'personal' regedit setting and did not get a successful install

I did a  find on return value 3 in the log for the error

MSI (s) (1C:48) [15:45:30:638]: Executing op: CustomActionSchedule(Action=CA_ConvertToUTF8,ActionType=1025,Source=BinaryData,Target=CAQuietExec,CustomActionData="powershell" -NoLogo -NonInteractive -InputFormat None –ExecutionPolicy Unrestricted -Command "if (Test-Path -path 'D:\Qlik\Engine\Settings.ini') {{ (Get-Content 'D:\Qlik\Engine\Settings.ini') | Set-Content -Encoding UTF8 -Force 'D:\Qlik\Engine\Settings.ini'" }})

MSI (s) (1C:38) [15:45:30:640]: Invoking remote custom action. DLL: C:\windows\Installer\MSI5B14.tmp, Entrypoint: CAQuietExec

MSI (s) (1C:4C) [15:45:30:640]: Generating random cookie.

MSI (s) (1C:4C) [15:45:30:648]: Created Custom Action Server with PID 400 (0x190).

MSI (s) (1C:7C) [15:45:30:693]: Running as a service.

MSI (s) (1C:7C) [15:45:30:695]: Hello, I'm your 32bit Impersonated custom action server.

CAQuietExec:  Error 0x80070002: Command failed to execute.

CAQuietExec:  Error 0x80070002: QuietExec Failed

CAQuietExec:  Error 0x80070002: Failed in ExecCommon method

CustomAction CA_ConvertToUTF8 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (s) (1C:48) [15:45:30:751]: User policy value 'DisableRollback' is 0

MSI (s) (1C:48) [15:45:30:751]: Machine policy value 'DisableRollback' is 0

Action ended 15:45:30: InstallFinalize. Return value 3.

This message occurs after the 32bit impersonated custom action server....the 64bit software has installed and is now rolledback.

I thought I may have problems with POWERSHELL in restricted mode.  I can't change the regedit setting.  If you can change the powershell policy group setting or if you can over-ride the installer  policy to disable the rollback (I can't) you may be able to get the software loaded.  I do not think most of us have access to this to update.  Any ideas?

Community Browser