Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

rmicklesavage
New Contributor II

Qlik Sense Engine Starting before Repository Service completes startup routine

In our development Qlik Sense 3.2.4 single node shared persistence environment we have an issue when the server is rebooted there are times that developers receive an error that the application is not accessible and asked to refresh the hub.  When this occurs we manually restart the services manually where I open the task manager to monitor the repository service as it goes through its startup routine, which takes about 30 seconds, as the service takes up to 60% of the CPU during the process and when it goes back down to 0 I start the engine and the issue is resolved.

Is there any documentation that addresses the fact that the engine starts before the repository service is complete starting and causes issues?

3 Replies
Employee
Employee

Re: Qlik Sense Engine Starting before Repository Service completes startup routine

Do you run on minimum 2 (dedicated) core? Did you check the repository log file? Sometimes when resources are scarce the repository service run out of time.

rmicklesavage
New Contributor II

Re: Qlik Sense Engine Starting before Repository Service completes startup routine

We have more than 2 dedicated cores running the software and I did look in the repository logs, but the resources are not being exhausted, its just that there are over 1600 apps in the environment and the process to process them seems to take longer than the engine is expecting.

Employee
Employee

Re: Qlik Sense Engine Starting before Repository Service completes startup routine

Did you also try to start the repo service as standard and all the other as "Start Delayed"?

Community Browser