Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

ralph_graham
New Contributor III

Qlik Sense - Windows Domain Authentication

Hello,

I'm having an issue with Windows authentication with Qlik Sense. With other installations the "out of the box" settings on the Virtual Proxy generally work however any time a user goes to the Qlik Sense Hub they are prompted to enter their username and password. Obviously this is not ideal or the expected outcome, (want them to automatically log in) and they are using supported browsers (e.g. Chrome and IE). In the log files I'm seeing the below error:

"Failed to acquire user principal name from directory services The specified directory service attribute or value does not exist."


I'm connected to Active Directory via User Directory so not sure why I'm getting this error.


Does anyone have any ideas?

Thanks,

Ralph

1 Solution

Accepted Solutions
awhitfield
Esteemed Contributor

Re: Qlik Sense - Windows Domain Authentication

Hi Ralph,

how's it going with this one? Any progress?

Best regards

Andy

6 Replies
awhitfield
Esteemed Contributor

Re: Qlik Sense - Windows Domain Authentication

Hi ralph,

it's actually browser config, check out, this link works for both IE and Chrome

https://sysadminspot.com/windows/google-chrome-and-ntlm-auto-logon-using-windows-authentication/

Worked fine for me.

Best regards

Andy

ralph_graham
New Contributor III

Re: Qlik Sense - Windows Domain Authentication

Hi Andy,

Thanks for the response. I'm assuming this only works locally though, i.e. if I change the settings on the browser through the server this won't be implemented globally?

Thanks,

Ralph

awhitfield
Esteemed Contributor

Re: Qlik Sense - Windows Domain Authentication

ralph_graham
New Contributor III

Re: Qlik Sense - Windows Domain Authentication

Thanks, I'll pass this onto the networks team to check.

Ralph

awhitfield
Esteemed Contributor

Re: Qlik Sense - Windows Domain Authentication

Hi Ralph,

how's it going with this one? Any progress?

Best regards

Andy

ralph_graham
New Contributor III

Re: Qlik Sense - Windows Domain Authentication

Yes, sorry for the late reply. The site needed to be added to a trusted local intranet zone through group policy so seems to be working as expected now.

Thanks,

Ralph

Community Browser