Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

frank_packer_at
New Contributor

Qlik Sense on Microsoft Azure

Hi All,

Hoping for some assistance with Qlik Sense on a Microsoft Azure environment,

I have set up a VM on an Azure platform and can connect to that with no issues. I set up IIS on the VM for testing purposes and can connect to that ok from the internet so the VM itself is all working properly (I've since uninstalled IIS).

My problem comes with setting up the Qlik Sense server to be accessible from the internet. It's installed and licensed fine on the VM and I can access the Management Console and the Hub locally when I remote desktop to the VM but I cannot seem to get it opened up for internet traffic.

I've set it up to allow HTTP and left the ports as their defaults.

I read a few forum posts about setting up the whitelist in the Virtual Proxies and I've tried a few things with that but it's not working, so clearly I'm still missing something. My understanding is that the whitelist needs to have the machine name for the VM in it or the IP address, and I've tried both options with no success so far - also noting that the IP Address will not be a good option due to that changing every time an Azure VM is shut down and restarted.

Perhaps there is some quirk with an Azure environment, or something else that I've missed in the installation process?

Any help would be appreciated!

1 Solution

Accepted Solutions
Not applicable

Re: Qlik Sense on Microsoft Azure

Is Windows Firewall on?  Start by turning it all off and testing.  Then if you need it turn it back on and open ports 80, 443, 4243, and 4244.

Jeff G

2 Replies
Not applicable

Re: Qlik Sense on Microsoft Azure

Is Windows Firewall on?  Start by turning it all off and testing.  Then if you need it turn it back on and open ports 80, 443, 4243, and 4244.

Jeff G

frank_packer_at
New Contributor

Re: Qlik Sense on Microsoft Azure

Ah, yes, thanks! Seems the obvious thing, now that you mention it but it never occurred to me to check that!

Community Browser