Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Qlik Sense server run failure after server rename

Good day, everyone! Need your help and advice as soon as possible.

The problem is the following. Our colleagues have renamed a Qlik Sense server by changing the host.cfg file after what it stopped working. The errors are 404 for qmc and for hub it just gives a directory html page with aspnet_client and web.config files. As I understood they did follow the guidelines below step by step except for the certificates stage (they did not delete old certificates as I have found them on the server).

https://support.qlik.com/articles/000014456

https://community.qlik.com/t5/Qlik-Sense-Deployment-Management/Rename-Qlik-Sense-Server/td-p/752813

I tried to backup to the previous host.cfg with the old name but it did not even let me to start up all the engine services. 

I also have noticed by comparing the settings that the broken server is not listening on 443 port, but haven't observed that any other services are listening on it. So I do not know whether the problem is in the port side or failure while renaming.

Would you advice to investigate on the errors or it would be just easier to delete and reinstall the server?

Would be very glad to receive any advice, please!

1 Reply
Highlighted

Hello,

Recreating the certificates is a mandatory steps when you change the server name.

The certificates are created based on the hostname mentioned in the host.cfg. 

Since the hostname has change there is name mismatch between the host.cfg and the certificates. 

Please follow this article to recreate the certificate. https://support.qlik.com/articles/000005402

The reason why the port 443 is not listening is most likely due to the Qlik Sense Repository not starting up (because of the name mismatch)

Without this service started, the rest won't follow. 

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.