Qlik Community

Ask a Question

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Rim Node Error "Database connection not reached".

Hi,

I am trying to setup a rim node and installing the software on the server, but I get the error as "Database connection not reached".

Can anyone please guide me here as to what could be the issue.

I have opened all ports listed on Qlik help for the same. My database resides on the Central node.

The Central node is up and working.

Thanks,

Nazira

10 Replies
Partner
Partner

When you install did you configure the database service listeners?

2w.jpg

Contributor II
Contributor II

Hi Herbert,

I have not yet reached that step.

I have tried to install the software on the server and after I choose the option of 'Join', the next step is to enter the database details and port(it prompts for 4 things) and gives an error there itself.

Please advise.

Thanks,

Nazira

Partner
Partner

This option you have to set on the Central Node installation(not the RIM node)

If you dont configure this way in central node when you try to communicate to the RIMs it will not work...

Contributor II
Contributor II

Hi Herbert,

Can you guide me through the steps as to how I can configure database service listener manually on central node?

Thanks for all your help!

Nazira

Partner
Partner

By default, the Postgres database installed by the Qlik Sense installer will only listen to requests from the local machine.

This may need to be configured to allow database access to the rim nodes.

  • If you installed a local database, the files are located in %ProgramData%\Qlik\Sense\Repository\PostgreSQL\\
  • If you set up a dedicated Postgres server, the files are located in %ProgramFiles%\PostgreSQL\9.3\data.

Do the following:

  • Copy the file postgresql.conf to another folder and open it in a text editor.
  • Locate the listen_addresses setting, uncomment it by removing the # symbol at the start of the line, and then set it to *:

​ listen_addresses = '*'

  • Set the maximum number of database connections to 100 x number of nodes in the Qlik Sense site:

​max_connections = 200 # this example is for a site with 2 nodes

  • Save the postgresql.conf file and copy it, replacing the existing file.

                                        ------------------------------

  • Copy the file pg_hba.conf to another folder and open it in a text editor.
  • Locate the following line:

host all all 127.0.0.1/32 md5

  • Add a subnet specification that covers the IP addresses of all nodes in your site can appear as such:

# IPv4 local connections:
host    all             all             0.0.0.0/0               md5
# IPv6 local connections:
host    all             all             ::0/0                      md5

  • Or add one row for each node, using /32 as suffix for each address, or add a subnet that covers all addresses using, for example, /24 as suffix.
  • Note: If you do not know which addresses to add, check with your system administrator. Qlik Sense 3.1 SR2 Shared Persistence | 24

  • Save the pg_hba.conf file and copy it, replacing the existing file.
  • If you installed a local database, restart Qlik Sense Repository Database. If you set up a dedicated Postgres server, restart postgresql service from Windows Services.
Partner
Partner

Hi Herbert88:

I'm getting the same error and I did the correct configuration in the central Node.

Can you please tell me what else can be the problem? ando how to fix it?

Thanks

Contributor
Contributor

We are experiencing the same error while installing the Qlik on Rim Node. 

QlikSense Version: QlikSense November2018 - 12.44.1

 

Can you advise me the steps to get it fixed.

Contributor
Contributor

Hi,

 

Did you fix your issue? If yes can you advise me the steps.

 

Thanks

Hari

Partner
Partner

Having the exact same issue.   Has anyone been able to resolve?  We have had two rim nodes for quite a while, but recently trying to add a third we can't get past this same database user info screen.