Qlik Community

Ask a Question

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Scheduler - Slave node not running any task

Hello,

I have a 4 nodes Qlik Sense 3.2.2 site (shared persistence) as follows:

  • Central Node - Proxy + Scheduler
  • RIM1 - Proxy + Scheduler
  • RIM2 - Engine + Printing
  • RIM3 - Engine + Printing


As you can see 2 of the nodes will be used for reloads (scheduler service). The configuration is as follows:


  • Central Node - Master and Slave
  • RIM1 - Slave


I am having the following problem: all the tasks are executed by the Central Node. I tried starting about 10 tasks at one time and all were started on Central node and none on the Slave node. Of course, 4 tasks started right away, the rest were queued.


I activated Debug log, and found the following entries in the log file:


  • Slave-node <RIM1> is not alive and cannot run task <task>
  • Slave-node <RIM1> is disabled and cannot run task <task>

Ports open through firewall as follows:

Central

Outbound -> 5151

Inbound   -> 5050


RIM1

Outbound -> 5050

Inbound   -> 5151

I have tried opening both ports in both directions on both servers, made no difference.

I also tried to change the Central Scheduler to Master only, but then the tasks will fail saying "no slave nodes found".

Any advise would be much appreciated!

Kind regards,

Mihai

2 Replies
Partner
Partner

Hi Mihai,

did you find the solution?

Kind Regards

Muhammad

Not applicable

Hi Muahmmad,

Yes I did. The fix is to have the Engine service installed and activated on the Scheduler Slave Node. I could not find any online documentation about this though...

Hope this helps.

Mihai