Qlik Community

Ask a Question

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Join us March 10th, 7 Ways Modern Analytics Can Help You Take Smarter Action. REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Sense doesn't install certificates

I'm having trouble reaching the Hub/QMC after removing my local certificates.

Followed some guide here: Re: Error 500 - Internal server error - Cannot establish a connection to Qlik Sense: Qlik Sense Mana...

, which suggested I remove the certificate and have Qlik Sense recreate them.

What ever I do they are not recreated and now I'm stuck.

See my logs which states:

Command=Start repository;Result=-1;ResultText=Error: Certificates are not correctly installed

I've tried starting/stopping/restarting the services multiple times. I even rebooted the machine.

I found some docs here: https://help.qlik.com/en-US/sense/September2017/Subsystems/PlanningQlikSenseDeployments/Content/Depl...

stating that "Recreate certificates by running the QRS in bootstrap mode."

The steps should be:

Do the following:

  1. Stop all Qlik Sense services except Qlik Sense Repository Database.
  2. Run repository.exe -bootstrap from an elevated command prompt.
  3. Start Qlik Sense services.

The output halts on Waiting for certificates to be installed (see screenshot). It's not possible to run repository in a non-elevated command prompt so that's not the issue.

More info: i'm running my Qlik Sense using an account named qsservice.

4 Replies

I am assuming that you're on Qlik Sense June 2017 or newer. From https://help.qlik.com/en-US/sense/September2017/Subsystems/PlanningQlikSenseDeployments/Content/Depl..., you are missing a key command line parameter. You ought to run Repository.exe -bootstrap -iscentral *. The waiting for certificates message is signaling that the node thinks it ought to be a RIM node, where certificates are distributed to it rather than generating their own.

Previous threads may've missed this distinction since historically Qlik Sense would re-generate certificates if needed. Due to the architectural changes needed to allow failover inside of Qlik Sense (STT - Failover in Qlik Sense - Practical Guide and Implications - YouTube) this step is needed.

* At some point it was Repository.exe -bootstrap -standalone so I typically would recommend running Repository.exe -bootstrap -standalone -iscentral which would eliminate any confusion.

Hope that helps.

Contributor III
Contributor III

This worked!

However, now I have a secondary problem that my proxy doesn't work, ie hub/qmc still unavailable.

See log for more info but basically

Web exception: Protocol error: Response stream exists. Remote endpoint 'https://localhost:4242/' [..] Not available Proxy Not available Not available Configure proxy -2146233079 Could not contact local repository to retrieve local server node configuration

If i open https://localhost:4242 in my browser I get a certification error (see attached screenshot).

The translation is roughly:

The server could not prove it's localhost since its certificate originates from static-

When removing all certificates via the MCC, Qlik generates another certificate from static- so how can this be an improper configuration?


It isn't an improper configuration. It's a misalignment of the host used (localhost) and the Common Name / Subject Alternative Name of the certificate (static- You can either click continue to get past this point or use the Chrome interstitial command "badidea" to bypass it (https://www.reddit.com/r/sysadmin/comments/42xd4i/chrome_danger_shortcut_changed_to_badidea/). 


this is very useful article ,follow this