Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Partner
Partner

Setting up a full access security rule for a Content Library in QMC

I have a user that I want to give access to a specific content library, but when the user tries to log into QMC everything is greyed out. I want the user to be able to access the Content Library menu, and be able to manage this single content library. Something is wrong in my security setup, but I can't see what it is.

The rule allows my user to access the content library from the hub.

1. Can anyone help me to figure out why my user is not able to access Content Libraries in QMC?

2. I notice that it is impossible to activate the "Create" checkbox in my security rule, why?

QMC setup (admin)

Skärmbild_111715_093933_AM.jpg

Security rule.jpg

QMC for the user in question (qlikbruker)

QMC.qlikbruker.png

Plees ekskuse my Swenglish and or Norweglish spelling misstakes
3 Replies
Employee
Employee

Re: Setting up a full access security rule for a Content Library in QMC

I might be oversimplifying this, but can you add the user role "ContentAdmin" to this user?

Partner
Partner

Re: Setting up a full access security rule for a Content Library in QMC

Unfortunately, Content Admin is an oversimplified solution. There are serveral content libraries on the production site that is off limits for the user in question. I really need to limit his access to this single content library.

Plees ekskuse my Swenglish and or Norweglish spelling misstakes
gsibecas
New Contributor

Re: Setting up a full access security rule for a Content Library in QMC

Hi,

First of all is better to create a new content library (ex:logistics content library).

The way I do it is creating a custom property (ex:contentcreators) for the users with some values (ex:logistics, finance) for each department.

After that I created a security rule(ex:logisticcontentcreators) with full acces to the content libraries with the rule user.@contentcreators="logistics".

I added this security rule to the content library and the custom property with the value "logistics" to the  user that needs the access.

 

Thats all, I hope will help ;D

Guillermo