Qlik Community

Ask a Question

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Talk to Experts Tuesday, January 26th at 10AM EST: Qlik Sense. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Unable to log onto Sense qmc / hub in Azure

Hello,

I have installed Qlik Sense 64bit on Azure server.

And it runs correctly when i log onto qmc in the server RDP (i am able to make apps etc).

When i try to connect to the hub from public internet, all i get the 'waiting' animation. It never shows any apps.

When i try to connect to the cmc from public internet i get the error message: "Connection is lost. Make sure that Qlik Sense is running properly.."

From Azure firewall I have opened the ports for 80 and 443. And also the proxy ports 4244 - 4248.

From qmc proxy settings i have allowed anonymous access.

I am puzzled, what is blocking the access?

1 Solution

Accepted Solutions
Support
Support

Yes, you can grant login access to anonymous users by creating a license rule.

  • Open QMC > License and Token
  • Select Login Access and create a new assignment and allocate tokens to it
  • Configure the license rule by setting user=userDirectory and value=NONE

or you can configure an advanced license rule with condition = user.IsAnonymous()

View solution in original post

12 Replies
Support
Support

Hi Joonas,

Have you added the external address you use to access hub/qmc into the Websocket origin white list on the proxy?

Go to QMC -> Proxies -> Edit proxy

Under Default proxy, locate Websocket origin white list and add the address being used when accessing hub/qmc

Not applicable

Yes i have added the external addres ***.cloudapp.net/hub to the white list

Support
Support

And you added endpoints on your VM in Azure for port 80,443 and 4244?

Oh, btw, the whitelist should be cloudapp.net only. you don't need wildcards, I think that's what's causing the problem

Not applicable

OK, now i have opened 4244 and white listed cloudapp.net.

The error message is "You cannot access Qlik Sense because you have no access pass" Can i make access pass to anonymous user?

Support
Support

Yes, you can grant login access to anonymous users by creating a license rule.

  • Open QMC > License and Token
  • Select Login Access and create a new assignment and allocate tokens to it
  • Configure the license rule by setting user=userDirectory and value=NONE

or you can configure an advanced license rule with condition = user.IsAnonymous()

View solution in original post

Not applicable

I'm having a similar problem -- Qlik Sense is installed and Hub/QMC run correctly on the Azure server via RDP.

However when trying to access via public internet, I simply get a "webpage not available" error. I've added the appropriate endpoints.

I'm hoping there is some simple/obvious configuration step I've overlooked -- either on the Windows Server/Azure or in Qlik Sense QMC  -- but can't figure out what. Any advice on steps to troubleshoot?

Support
Support

Hi Rob, Below is a checklist that may help out.

Azure configuration

Configured Endpoints

NamePublic portPrivate port
HTTP8080
HTTPS443443
QlikSenseAuth42444244
RDPdynamic3389

Firewall rules (in Windows):

Allow ports 443 and 4244

Qlik Sense configuration

Add external domain (cloudapp.net) to Web socket origin white list in QMC

QMC > Proxies > (Edit) Central Proxy

Untitled.png

I think that should be pretty much it to be honest. Just remember, if you access Qlik Sense using your own domain (instead of cloudapp.net), then you need to add this into the white list as well.

Not applicable

Thanks. Turned out to be the Windows Firewall.

Everything working fine now!

Not applicable

Hi,

slightly off-topic, but worth sharing in case you are new to Azure..

Your users will most likely receive timeout in their browsers if they are idle for 4½ minutes, unless you change the "IdleTimeOutInMinutes" for endpoint 443 in Azure. We experienced this issue among our users in both QlikView and QlikSense, which they found very frustrating..

More info here:

http://azure.microsoft.com/blog/2014/08/14/new-configurable-idle-timeout-for-azure-load-balancer/