Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

Upgrading Qlik Sense Repository from 9.6 to 11.5

 Hi,

I would like to ask if it is possible to upgrade the postgresql repository of Qlik Sense (version Feb 2019) from 9.6 to 11.5.

It says here that there are vulnerabilities in the current version that can be resolved by upgrading the version of postgresql: https://www.cvedetails.com/vulnerability-list/vendor_id-336/product_id-575/Postgresql-Postgresql.htm...

If it's possible to upgrade the postgresql repository, are there any drawbacks of upgrading? Are there any pre-requisite? Are there things that I should know about? We currently have a multi-node setup (1 central, 2 rim nodes), are there any configurations that I need to do on all nodes?

Sincerely, 
Rey

1 Solution
10 Replies
Highlighted
Support
Support

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @reycarloluber 

The requirement for that version is PostgreSQL  9.6

https://help.qlik.com/en-US/sense/February2019/Subsystems/PlanningQlikSenseDeployments/Content/Sense...

Kind regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/
Highlighted
Contributor III
Contributor III

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi Nadia,

Thanks for the reply!

9.6 already came upon installation. What I would like to know is if upgrading is possible or if it'd have any impact in the on-going environment. Any pre requisite or things to note are also highly appreciated.

Sincerely,
Rey
Highlighted
Support
Support

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @premvihari 

If you upgrade and after that there is a problem, as the version is not listed in the requirements it won't be a supported installation.

 

Kind regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/
Highlighted
Contributor III
Contributor III

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @NadiaG 

Can you please elaborate what you meant by it not being a supported installation? I followed the guides posted by @premvihari  and was able to replace (not upgrade) the postgresql from 9.6 to 11.5 and everything is working as is.

Sincerely,

Rey

Highlighted
Support
Support

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @premvihari 

Please refer to the Support Policy , 4. Error Resolution and Escalation, 4.2 section.

It is necessary to verify your system meets the Requirements listed in the documentation.

Kind Regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/
Highlighted
Contributor III
Contributor III

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @NadiaG ,

Thank you for the reply. If we downgrade back to 9.6, will it be covered by the support again? And also, are all patches of 9.6 covered by the support? We are planning to downgrade back to 9.6.15.

I am not sure if only 9.6.6 is covered. We need at least 9.6.10 to address the vulnerability issues.

Sincerely,

Rey

Highlighted
Support
Support

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Hi @reycarloluber 

Have you had the chance to look at the documentation? It is mentioned that is required PostgreSQL 9.6.x versions

https://help.qlik.com/en-US/sense/February2019/Subsystems/PlanningQlikSenseDeployments/Content/Sense...

 

Kind Regards.

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/
Highlighted
Employee
Employee

Re: Upgrading Qlik Sense Repository from 9.6 to 11.5

Qlik Sense Enterprise (as of October 2019) only supported PostgreSQL 9.6.x. There are active plans to support higher versions of PostgreSQL and the goal is to include this into Qlik Sense November 2019, although that is not a commit that it will make it into November 2019. Practically this is planned to be support of a remote PostgreSQL site with 11.x initially with later releases supporting upgrading the bundled PostgreSQL which comes with Qlik Sense Enterprise. Please check the system requirements page on help as releases are released to see when this change is made.