Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
See why Qlik is recognized as a Leader for the 10th year in a row – and discover how Qlik can help put your business in the lead. Get Report
quriouss
Contributor III

User unable to create App - "no response was received from the server"

This is a new-ish installation of Qlik Sense, and one of my first users is unable to create an App.

The error they are getting is;

No response from the server

No response was received from the server when attempting to create the app. Please try again if the app was not created.

03-09-2015 18-02-39.png

I have tried opening up the security roles - there is an role for App_* for !user.IsAnonymous() with the permission of Create.

It seems to me like there might be some sort of access problem on the server - do I have to change folder/file permissions to allow the users to create their apps?  My server is running under system account and I can't find anything about this in the installation guides I have.

6 Replies
Highlighted
Partner
Partner

Re: User unable to create App - "no response was received from the server"

Quriouss‌,

Anonymous users are not able to create/publish by default.  They are read only.

-ckb

Highlighted
quriouss
Contributor III

Re: User unable to create App - "no response was received from the server"

Correct. The security rule ‌is for !user.IsAnonymous() - note the exclamation mark, meaning "not". So the rule should be read as "any user who is not Anonymous can create".

Highlighted
Partner
Partner

Re: User unable to create App - "no response was received from the server"

I misread your post and thought you meant that the user trying to create the app was anonymous.

Are you only seeing this issue with one user or with multiple different users?

-ckb

Highlighted
quriouss
Contributor III

Re: User unable to create App - "no response was received from the server"

Only one user has reported the issue, but this is a brand new installation and I'm not sure anybody else has tried to create an app yet.

I gave the user the "Content Administrator" role, but they still can't create, which suggests the issue is in the file system.

(I am able to create, but I have admin rights on the server and I am the administrator for the Qlik Sense installation as well, so that's not surprising.)

Highlighted
Partner
Partner

Re: User unable to create App - "no response was received from the server"

You said your services are running under a system account, is it the local system account? 

If so, I would recommend you create a service account specifically for Sense and add it to the administrators group.

If you are already doing that, my next test would be to see if other non-admin users experience the same issue.

hth

-ckb

Highlighted
quriouss
Contributor III

Re: User unable to create App - "no response was received from the server"

Thanks - i wasn't able to get to the bottom of this so I just gave them a Content Admin role for now - I will have to revisit it when possible.

The fact that the Qlik Admin role works (with the same login details) suggests the problem is my Qlik configuration, rather than Windows security (which makes sense).

Thanks for your time.