Qlik Community

Qlik Sense Enterprise Documents & Videos

Documents & videos about Qlik Sense.

Frustrate XML between Qlikview Vs Qliksense

Frustrate XML between Qlikview Vs Qliksense

Hi Guys,

I am frustrating initially why Qlikview loading as expected but Qliksense not during loading from XML.

I have my XML which is not reading properly by Qlik and they key generating is different.

Example of XML:

<product acId="125">
<attributes>
<attribute name="Product Family">Repurchase Agreements</attribute>
<attribute name="Product Type">Repurchase Agreements1</attribute>
<attribute name="IsUsage">Yes</attribute>
<attribute name="Sales Points">
<values>
<value>10</value>
<value>20</value>
</values>
</attribute>
</attributes>
</product>

Outcome:

XML Output.PNG

Qliksense is reading If attribute is alone not along with Element which is Values? I have 2 solutions so far to achieve this?

XML is small What i've attached in this document but it is actually in GB's hence I have some ready mate script for you guys let me know, If at least one person can turn around If you have any use case like above.

XML Attached just load it and see how this script running? 

I would strongly preferred try only "XML Experiment 1.qvf" because 2.qvf has some risks as follows

1) If we change any attribute, this file not reading

2) If we change any element file don't know which %Key based it got generated

3) If we add another attribute which is different than this again need to load with all directory structure etc.

 

Best,

SAB

Attachments
Version history
Revision #:
4 of 4
Last update:
3 weeks ago
Updated by:
 
Contributors