Qlik Community

Ask a Question

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Join us March 10th, 7 Ways Modern Analytics Can Help You Take Smarter Action. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Digvijay_Singh
Master III
Master III

Visualization API -measure sorting doesn't work in Qlik Sense Sept release

Hi,

We have one strange bug, , Measure sorting in visualization API is not working in Sept release, anyone has any idea on this?

It works fine in Nov release.

This below code works perfectly in nov release but not in sept release

var objField = {};

            objField.qLibraryId = "WZuPmc";

            objField.qType = "measure";

            objField.qLabel = "";

            objField.autoSort = false;

            objField.qSortBy = {};

            objField.qSortBy.qSortByNumeric = salesperformance.chartorder == -1 ? -1 : 1;

            transactionDimensions.push(objField);

objHyperCube.qHyperCubeDef.qInterColumnSortOrder = [1,0,2];

app.visualization.create(chartType, transactionDimensions, objHyperCube).then(function (vis) {

I shared excerpts of the code, just to indicate that all needed ingredients are present, and it works perfectly in Nov release

tried without library id , using qDef definition, that also doesn't work.

Thanks in advance for all the help.

Thanks,

mto

mbj

erik.wetterberg

1 Solution

Accepted Solutions
bgk
Employee
Employee

Hello digvijay

This is indeed a bug which was found on the September release and fixed for the November release.

Best Regards

Jonas

View solution in original post

4 Replies
ErikWetterberg

bgk
Employee
Employee

Hello digvijay

This is indeed a bug which was found on the September release and fixed for the November release.

Best Regards

Jonas

View solution in original post

Digvijay_Singh
Master III
Master III

Thanks for confirming!

Digvijay_Singh
Master III
Master III

Thanks Erik, I raised the support ticket on this. Lets see what they respond, looks like a bug in sept release.