Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
Showing results for 
Search instead for 
Did you mean: 
Not applicable

cant LINK SHEET into a image

Hi guys,

i have been trying link an image to another sheet but i dont have luck.

I was trying to link it with Qlik dev Hub creating new functions, and also i was trying to link it with expressions, downloading new projects... but i couldn't get it...

I think there should be an easy way... by expression in "link to url" with a "Text & Image" extension,or something like that i dont know.

Can anyone help with that?

Thanks a lot!

PD: I have been reading a lot of articles of Sangram Reddy @DsSangram and Stefan Walther , and you are awesome!

4 Replies
Not applicable

Hi Alvaro,

You are right. There is a way to link sheets through "Text and Image" Object.

In Qlik Dev Hub, under 'Single Configurator', you have to select the sheet which should be displayed after the image click.

You will get a URL there of that particular sheet in the 'URL' option. Copy the URL.

In your App, drag the 'Text and Image' object and add the image. Click on the image and in the 'Create link' option, paste the URL.

So on image click, the sheet of which the URL you have provided will open.



Not applicable

Hi Rohan,

first of all, thank you for answering me.

I think you are referring when you have a Qlik Sense Server. I didn't say but i am woking with Qlik Sense Desktop.

I've tried what you say. I tried this:

1.- Copying the ID of the sheet that i want and copy it in Visualitazions Extensions.

2.- Copying iFrame and pasted it into "link url" in qlik sense desktop

3.- Copying url and pasted it into "link url" in qlik sense desktop

Doesnt work with points 1 and 2, but with third point, when pasted the url, and i tried to open it, Internet explorer shows me "Format its no supported" or something else.

Fortunately now i have a Qlik Sense Server, and i dont have this problem because with the Server lets you copy and paste url's.

But i think its necesary works in Qlik Sense Desktop.

Thanks again.

Not applicable

Hi Alvaro, 

That's strange.

Yes , you can only copy the URL in the "link URL".

Try turning the firewall and antivirus off. And hope you are using Internet Explorer 10 or higher.

Here is a video by Michael Tarallo  that may help you.



Not applicable

Hi Rohan,

thanks again for your help.

Im in a company and i dont have permissions to turn off the firewall to avoid it.

However, i will watch again all videos of Michael Tarello.

I will close this post because i have a alternative solution.

Thanks again guys.

Kind Regards.