Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

Extension on QlikSense Enterprise

Hi guys!

We are testing extensions on QlikSense Desktop and everything works fine.

However, in Enterprise version (Server), when i try to create a project in the dev-hub i get an error: "no templates for visualization extensioons or mashups where found in your system"!

Using QMC, I tried to import a extension that comes in the ProgramData\Qlik\Examples\Extensions\Templates folder, but i had no sucess too.

What possibly i am doing wrong? Help!

4 Replies

Re: Extension on QlikSense Enterprise


I assume you are working with Qlik Sense 2.1.1?

I this is the case, have a look at:

Maybe you can also elaborate a bit: What does "I tried to import ... but I had no success"? What happened?

Hope this helps.




Re: Extension on QlikSense Enterprise

Hi Wilson,

Can you provide us more details about the version you are trying to install?

And as Stefan mentioned, what happened when you tried to import the extensions?



Not applicable

Re: Extension on QlikSense Enterprise

Hi Guys, thanks for the answers!

In fact, all we wan't to do is create a new visualization extension in QlikSense Enterprise v. 2.1.1. Could be an empty one, after all we have the code that we created using QlikSense Desktop, so it would be just a Ctrl+C, Ctrl+V operation.

The first error ocurred when i tried to create a "New Project", in dev-hub:


After this, i tried to import a extension that came with the QlikSense installation, located on folder C:\ProgramData\Qlik\Examples\Extensions\Templates\basic-template.


And another error ocurred: exactly the one that shows on the PDF you send:

The worst thing is there are nothing on the logs to enlight the question! 

Any help!?

About the pdf you have send, here is one question: do I have to add mime types to import a extension that come with the installation of the product? Strange...


Re: Extension on QlikSense Enterprise

Hi Wilson,

   To me it looks like the template that you are trying to upload already exist in your QMC Extension list, can you confirm?


- Do you have extension or templates in this list?

- have you created a special security rule, that will not allow you "read" extensions?

You should also try to change the name of that extension (folder+filename+in the qext file) then try to upload it again.