Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

eddysunn
New Contributor III

Extensions on Qlik Sense Server not functioning properly

Hi Community!

I have recently installed a Qlik Sense Server. I imported a few apps from my Sense Desktop to the server. Then I imported the downloaded ZIP file for the all famous "variable" extension.

Now, the extension appears on the screen as supposed, but when i change my selections in that variable, it does not affect (make changes to) anything that is bound to it.

Is there something I am missing to make it work?

Regards,

Edil

1 Solution

Accepted Solutions
erik_wetterberg
Honored Contributor

Re: Extensions on Qlik Sense Server not functioning properly

What version och the extension är you using? I'm afraid there was a bug in the 3.0.0 version, that might cause your problem. Try download the latest version.

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
6 Replies
erik_wetterberg
Honored Contributor

Re: Extensions on Qlik Sense Server not functioning properly

Hi Edil,

Does the extension work properly? Thats is, if you select a value, does it stay selected?

How do you refer to the variable in your app? Do you use $ expansion??

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
eddysunn
New Contributor III

Re: Extensions on Qlik Sense Server not functioning properly

Hi Erik,

1. Went and tried it out. When I change a selection in the variable and then click on any other selection graph, the variable selection returns back to default. During the whole process the value assigned to it does not change on screen (i.e. I put a text field that would represent my variable 'Your choice is: ' & $(vRate) ).

2. Yes, i use the $(vRate) format.

In the desktop app it was working all good, but now this is happening on Server after import.

erik_wetterberg
Honored Contributor

Re: Extensions on Qlik Sense Server not functioning properly

What version och the extension är you using? I'm afraid there was a bug in the 3.0.0 version, that might cause your problem. Try download the latest version.

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
eddysunn
New Contributor III

Re: Extensions on Qlik Sense Server not functioning properly

I went to github and went through the readme file for (your? ) variable extension. Then I checked my Qlik Sense Server version. And it looked like the latest version does not work properly in my version. So I uninstalled the extension that i installed before, downloaded the previous version and everything worked like a charm!

Thanks Erik!

erik_wetterberg
Honored Contributor

Re: Extensions on Qlik Sense Server not functioning properly

Yes, that's my extension. So you are using 3.2 SR3 or 4? I'm afraid they have a bug that breaks the extension.

Erik

Erik Wetterberg
https://extendingqlik.upper88.com/
eddysunn
New Contributor III

Re: Extensions on Qlik Sense Server not functioning properly

It is 3.2 SR4. Thanks for help Erik!

Community Browser