Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

stuartholms
New Contributor

Missing Pie & Doughnut Published App Enterprise API

Hey,

We have a number of apps embedded in our website using the API.

If I view one of the apps in the hub there is a number of visualisations on the sheet including a doughnut chart.


When we view the same app on the website there is nothing displayed where the doughnut chart should be.


The developers have reported that there is an error the following file is missing.


<hostname>/resources/assets/external/sense-themes-default/default-themes.json.js


We did a test with an App the contained just a pie chart and we get the same behaviour.


We're running Qlik Sense Enterprise September 2018


image.png

1 Solution

Accepted Solutions
erik_wetterberg
Valued Contributor III

Re: Missing Pie & Doughnut Published App Enterprise API

Hi,

Not sure that this will help with the pie, but the missing file default-themes.json.js is probably because requirejs adds '.js' when it tries to load a non-js file from another server. You can turn this off by configuring useXhr to a function returning true in your mashup. Described in this thread:

Re: June 2018 - Mashup on external webserver

Erik Wetterberg

https://extendingqlik.upper88.com/

https://extendingqlik.upper88.com/
2 Replies
erik_wetterberg
Valued Contributor III

Re: Missing Pie & Doughnut Published App Enterprise API

Hi,

Not sure that this will help with the pie, but the missing file default-themes.json.js is probably because requirejs adds '.js' when it tries to load a non-js file from another server. You can turn this off by configuring useXhr to a function returning true in your mashup. Described in this thread:

Re: June 2018 - Mashup on external webserver

Erik Wetterberg

https://extendingqlik.upper88.com/

https://extendingqlik.upper88.com/
stuartholms
New Contributor

Re: Missing Pie & Doughnut Published App Enterprise API

Reply from our devs -

The response in qlik community helped. It didn't work at first but then changing it to use requirejs sorted it.