Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Not applicable

NuGet Package

Is there any reason why the QlikSense nuget package requires specific versions of it's dependencies?

Especially the JSON element, there is that many libraries, including Microsoft's own libraries that use it your almost destined to get a dependency conflict...

For instance:

Unable to resolve dependencies. 'Newtonsoft.Json 7.0.1' is not compatible with 'Microsoft.Owin.Security.OAuth 3.0.1 constraint: Newtonsoft.Json (≥ 6.0.4)', 'QlikAuthNet 1.1.1 constraint: Newtonsoft.Json (≥ 6.0.0)', 'QlikSense.NetSDK 2.0.3 constraint: Newtonsoft.Json (= 6.0.3)', 'Westwind.Globalization 2.1.0 constraint: Newtonsoft.Json (≥ 6.0.8)', 'Westwind.Web 2.64.0 constraint: Newtonsoft.Json (≥ 6.0.8)'.

1 Solution

Accepted Solutions
Employee
Employee

Re: NuGet Package

This is a known issue. Please refer to the following thread for more information:

.Net SDK nuget package

2 Replies
Employee
Employee

Re: NuGet Package

This is a known issue. Please refer to the following thread for more information:

.Net SDK nuget package

Not applicable

Re: NuGet Package

Thanks, apologies for the duplicate

Community Browser