Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Highlighted
nicolaurodrigues
New Contributor

Qlik Sense Mashup error after upgrade

Hello guys,

We made an upgraded Qlik Sense 3.2 R3, which used token-type licenses, for the new version of Qlik released in November 2019 that uses Analyzer licenses.

One of the features we used, and used to run without problems, It was using a JavaScript file to access the Mashup to identify all filters selected on a dashboard.

The settings that were made are in the "PIC 1" image bellow:

pic1.pngPIC 1 - Our coding using require(js/qlik)

But after upgrading the Qlik version, the code no longer works. It throws the error shown in the "PIC 2" image bellow.

pic2.pngPIC 2 - Error returned in the chrome inspect screen

Checking the qlik.js file, which is  called in the require function and found in the C:\Program Files\Qlik\Sense\Client\js path of our server, we noticed that was very changed compared to previous version used.

And it loads the qlik-require-plugin.js file. These two files contain the following codes:

pic3.pngPIC 3 - Checking the files qlik-require-plugin.js and qlik.js files

This is the Sources of our code:

pic4.pngPIC 4 - The sources of our code

Tags (3)