Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Not applicable

Re: Mashup API context

Hi, ewg

We are currently using Qlik Sense 1.1 and perhaps something have changed since version 1.0 but we are running into following issue:

We want to pull Qlik Sense objects from our remote web site using Mashup API but are getting the following 403 error when opening an app:

qlik_error_response.PNG

From what I understand CORS has nothing to do with it since websockets are not restrained by the same origin policy. and also other files like qlik.js, client.js were loaded without any problems. So it must be the Qlik Sense server that enforces the origin policy.

So the question is: is there a way to allow origin on the server, so the handshake is carried successfully?

1 Solution

Accepted Solutions
Employee
Employee

Re: Mashup API context

Try just allowing rustam-pc.cl.local alternatively you could add localhost to your white list and try browsing your website from localhost:3000 and see if it helps.

Edit: Also it looks like you are running a virtual proxy so make sure you are setting the whitelist for the correct proxy.
Btw it looks like you are getting dual session cookies also, are you sure that you are setting the correct prefix?

4 Replies
erik_wetterberg
Honored Contributor

Re: Mashup API context

Hi Rustam,

from the screenshot it looks like you are using ws:, should probably be wss:

Check out the config object, usually in the beginning of the javascript file:

var config = {

   host: window.location.hostname,

   prefix: prefix,

   port: window.location.port,

   isSecure: window.location.protocol === "https:"


};

Try setting isSecure to true.

Erik

Erik Wetterberg
https://extendingqlik.upper88.com/
Not applicable

Re: Mashup API context

Thanks for the answer, Erik!

Same error unfortunatelyqlik_error_response.PNG

I've also tried adding client host to the websocket origin white list with no success either...

web_socket_white_list.PNG

Employee
Employee

Re: Mashup API context

Try just allowing rustam-pc.cl.local alternatively you could add localhost to your white list and try browsing your website from localhost:3000 and see if it helps.

Edit: Also it looks like you are running a virtual proxy so make sure you are setting the whitelist for the correct proxy.
Btw it looks like you are getting dual session cookies also, are you sure that you are setting the correct prefix?

Not applicable

Re: Mashup API context

Thanks, Alexander!

Allowing domain without port number did the job.

Community Browser