Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Not applicable

Section access problems with Qlik Sense server?

Hi,

I have a load script with section access and it loads ok on the Sense server and everything seems to be allright. I try to open single view with qlik ticket I'm able to get via API with UserId-attribute linked to the USERID in my load script. It starts to open the view when I try to open it with the ticket and I can see that login access user is created to the QMC -> Users (so the ticket is consumed), but when the view is opened, there comes "Access denied (null)" error and then an error with a message "No object with Id xxxx1 found".

What does this message mean and is there a log from where I could see what's happening?

BR, Petteri

5 Replies
alextimofeyev
Contributor II

Re: Section access problems with Qlik Sense server?

Petteri,

I seem to have a similar issue. Are you using one user to log in on the server and a different user to log in with the ticket?

Alex

arasantorule
Contributor III

Re: Section access problems with Qlik Sense server?

Hi Petteri,

I believe, the ticket is consumed because the user has logged in to the access point. But the error occurs when you/API try to access the application.

Can you please provide more details on this.

Thanks.

alextimofeyev
Contributor II

Re: Section access problems with Qlik Sense server?

I think I found the reason for the issue I was experiencing. My QS version is 2.03, and this is from the 2.04 release notes (bug fixes):

Section Access - Access Denied using GROUP attribute for USERID with special characters Jira issue ID: QLIK-39389, QLIK-40021 If special characters, such as @, are used in a USERID of a user included in a GROUP, the user is denied access.

alextimofeyev
Contributor II

Re: Section access problems with Qlik Sense server?

Hi petteri.ainohealth,

were you able to resolve your problem. In my case, update to QS 2.0.6 did the trick.

Alex

Not applicable

Re: Section access problems with Qlik Sense server?

Hi,

thanks for your answers but I got it now working. I hadn't realized that I have to add also the user directory information in to the beginning of the USERID when I create the custom USERID from my database table user_id e.g.:

LOAD

  'USERDIRECTORY_XYZ\' & Upper(user_id) as USERID, ...

and then include the same user directory to the JSON calling the ticket, e.g.:

{

  "UserDirectory":"USERDIRECTORY_XYZ",

   "UserId":"87234"

}

And now when my web app receives the ticket and when I open a view in my web app where I've embedded Qlik-sheet to iframe, it works ok and the user that has logged in to my web app can only access his/her data!

-Petteri

Community Browser