Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

berndpodhradsky
New Contributor II

Single Integration API Callbacks not working using HTTPS?

Hi everyone!

Qlik Sense documentation states that callbacks may be received by adding the "callback=test" parameter to the single object URL. Here's the link to the documentation:

https://help.qlik.com/en-US/sense-developer/September2017/Subsystems/APIs/Content/single-integration...

This works perfectly well when using HTTP - I get two alert boxes notifying me of the callbacks. However, when using the exact same URL with HTTPS, I don't get any alert boxes. Why is that the case? And is there any other way to catch onError, onValid and onRendered? How can I find out whether the single object integrated in my webpage has finished rendering or has produced any error?

Thanks in advance,

Bernd

2 Replies
erik_wetterberg
Valued Contributor III

Re: Single Integration API Callbacks not working using HTTPS?

Hi Bernd!

Do you actually use the built-in test package? In that case you should be able to step through the callbacks in the debugger. Or have you added your own handler? Might be that Internet Explorer has some security restriction on whats possible to do.

Hope this is of some help

Erik Wetterberg

Erik Wetterberg
https://extendingqlik.upper88.com/
berndpodhradsky
New Contributor II

Re: Single Integration API Callbacks not working using HTTPS?

‌Hi Erik!

All I‘ve done so far is adding &callback=test to the single object URL and opening it in the browser. The browser displays two alert boxes when using HTTP. The same URL (just using HTTPS) gives no alert box at all.

How can I register my own callback functions? I have not found any information about that in the documentation. Is there a simple example (HTML website with one embeded single object plus callback receivers)?

Thank you in advance,

Bernd

Community Browser