Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

davequinn
New Contributor II

'Tweaked' PeopleChart extension renders differently in Hub and Browser

First post, so hope this isn't too stupid...

Experimenting with Extensions I modified the css file for the supplied PeopleChart extension to make it use an local image.

.qv-object-com-qliktech-peoplechart .bar {

  float:left;

  height:32px;

  clear:right;

    background: url("/extensions/com-qliktech-peoplechart/person.png");

}

Oddly this seems to work in a browser from http://localhost:4848/hub/my/work ‌but when viewed in the Hub I still see the original graphic

Browser: Capture2.PNG

Hub: HubCapture.PNG

Thanks in advance for any assistance,

David

1 Solution

Accepted Solutions
erik_wetterberg
Honored Contributor

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

So you've found the DevTools in the bundled browser. An instruction on this is here. What you could try is switch to the 'Network' tab and then check the 'Disable cache' checkbox.

Capture.PNG

Keep the DevTools open, then switch back to your sheet and refresh.

Hope this helps

Erik

Please mark the appropriate replies as correct or helpful so our team and other members know that your question has been answered to your satisfaction.

Erik Wetterberg
https://extendingqlik.upper88.com/
6 Replies
erik_wetterberg
Honored Contributor

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

Hi David,

Open the console, you'll probably have a HTTP 400 for your image file.

Do you use a virtual proxy in your server deployment? Your link to the image is an absolute path, so it won't work with a virtual proxy, where the proxy should be before '/extensions'. Best solution is to use a relative link instead. That will work in the client., but if you use the extension in a mashup it will probably break. To solve this you probably need to encode your image and include it in the css file, like the original.

Hope this helps

Erik

Please mark the appropriate replies as correct or helpful so our team and other members know that your question has been answered to your satisfaction.

Erik Wetterberg
https://extendingqlik.upper88.com/
davequinn
New Contributor II

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

Sorry - I should have said that this is Qlik Sense Desktop (Version 2.1.1 + Build:22.origin/release/ms13)

erik_wetterberg
Honored Contributor

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

Oh, so you get the old version in the built-in browser, but the fixed one in Chrome?? I'm afraid the built-in browser caches quite agressively, you shouldn't really use it for extension development. It might help if you restart Qlik Sense desktop.

My previous comments are still valid if you intend to deploy your extension to a server: avoid absolute paths since they will break if you have a virtual prefix on your server.

Erik

Please mark the appropriate replies as correct or helpful so our team and other members know that your question has been answered to your satisfaction.

Erik Wetterberg
https://extendingqlik.upper88.com/
davequinn
New Contributor II

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

Thanks Erik.

restarting doesn't help. Dev-tools showing a cache miss error though:

Failed to load resource: net::ERR_CACHE_MISS

http://localhost:4848/sense/app/C%3A%5CUsers%5Cext_dqu%5CDocuments%5CQlik%5CSense%5CApps%5Cextension...

Any ideas what the bundled Chromium browser might be doing differently? It is working fine in both Chrome and Internet Explorer...

erik_wetterberg
Honored Contributor

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

So you've found the DevTools in the bundled browser. An instruction on this is here. What you could try is switch to the 'Network' tab and then check the 'Disable cache' checkbox.

Capture.PNG

Keep the DevTools open, then switch back to your sheet and refresh.

Hope this helps

Erik

Please mark the appropriate replies as correct or helpful so our team and other members know that your question has been answered to your satisfaction.

Erik Wetterberg
https://extendingqlik.upper88.com/
davequinn
New Contributor II

Re: 'Tweaked' PeopleChart extension renders differently in Hub and Browser

Erik,

thank you. I'm going to mark that answer correct, though what actually happened was that when I logged in to try your suggestion the visualisation worked correctly all on its own. I'm guessing that the cached information had aged out and been refreshed.

Thanks for your help,

David

Community Browser