Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

dvasseur
Contributor II

proxyRestUri and proxied QS server

I'm playing with external authentication (Google SSO) and noticed that the proxyRestUri il always using the real server hostname, Not the one I've used in my connection URL. Could be annoying because my QS server is proxied through nginx...

For example:

_https://nginx/google <- link to QS virtual proxy 'google'

redirects me to:

_https://qlik-auth/?proxyRestUri=https%3a%2f%2fsrv-vm-qs%3a4243%2fqps%2fgoogle%2f&targetId=0d7b5f6a-b0f5-4721-886c-daf011d798c2

the proxyRestUri should be "proxyRestUri=https%3a%2f%2fnginx%3a4243%2fqps%2fgoogle%2f&targetId=0d7b5f6a-b0f5-4721-886c-daf011d798c2" instead of "srv-vm-qs" which is my real server name

Any idea to fix this ? I couldn't find any option for this in the QMC

2 Replies
Employee
Employee

Re: proxyRestUri and proxied QS server

Are the values here:

tvNxxg5.png

dvasseur
Contributor II

Re: proxyRestUri and proxied QS server

Hi Levi,

According to the docs, no, but I have tried anyway and definitely not working

Community Browser