Qlik Community

Qlik Sense SaaS & Multi-Cloud

Discussion board where members can get learn more about SaaS & Multi-Cloud deployments for Qlik Sense.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Specialist III
Specialist III

Error while Installing Qlik Sense in Kubernetes

HI Techies,

 

I have started working on  Installing Qlik Sense in Kubernetes on my local personal windows 10, 8 Gb ram and 4 core machine.

I am referring the document made by Qlik know expert 

https://github.com/tonikautto/qse-kubernetes-minikube

 

Now above document has two files 

1.  0-install-tools.ps1 which guide us to install tools, reference Qlik doc behind the powershell file is 

https://help.qlik.com/en-US/sense/April2019/Subsystems/PlanningQlikSenseDeployments/Content/Sense_De...

I ran it and it was executed fine with no errors.

now I have Oracle VM virtual box manager, minkube, which is running fine.

 Then I ran second file 1-Deploy-Minikube.ps1 which is made by https://help.qlik.com/en-US/sense/April2019/Subsystems/PlanningQlikSenseDeployments/Content/Sense_De...

It has commands to

kick off minikube start, 

# Force Kubectl to point to minikube, 

# Run the following command to add Qlik’s helm chart repository to Helm. This is where Qlik Sense is pulled from

# use helm to deploy into Kubernetes, the helm Tiller pod is added to the Kubernetes cluster first.

# Install custom resource definitions used by dynamic engines

but when it try to execute 

# Install the Qlik Sense package

helm install -n qliksense qlik/qliksense -f values.yaml

it gives me error:

Error: validation failed: error validating "": error validating data: unknown object type "nil" in Secret.data.redis-password

, I tried to run the command by going to the folder where values.yaml but same error.

I have not much knowledge about Kubernetes so please help me to fix the error step wise step ?

 

Thanks in advance

Rohit 

 

1 Solution

Accepted Solutions
Highlighted
Employee
Employee

I had the exact same error message, and resolved per my noticed in GitHub. It does still suggest that you tool installation is not accurate. 

This is not a Qlik error message form what I can tell, so you need broaden your investigation towards the non-Qlik tools. 

View solution in original post

15 Replies
Highlighted
Support
Support

That's a bug with the latest version of Helm. You'll need to downgrade Helm:

 

echo 'Getting Helm'
curl -s https://raw.githubusercontent.com/kubernetes/helm/master/scripts/get > get_helm.sh
chmod 700 get_helm.sh
./get_helm.sh --version v2.13.1

 

Highlighted
Specialist III
Specialist III

Hey Chris,

When I write your code in .ps1 file as:

echo 'Getting Helm'

curl -s https://raw.githubusercontent.com/kubernetes/helm/master/scripts/get > get_helm.sh

chmod 700 get_helm.sh

./get_helm.sh --version v2.13.1

 

it is asking for:

"cmdlet Invoke-WebRequest at command pipeline position 1
Supply values for the following parameters:
Uri:"

Then I am not sure which value to enter ?

Can you please  guide me how to downgrade helm step wise ?

 

Thanks,

Rohit

 

 

Highlighted
Specialist III
Specialist III

Hey Chris,
Can you please help me to downgrade helm ?

Thanks,
Rohit
Highlighted
Support
Support

Hey Rohit,

Like most things with Linux, it's all highly dependent on your setup. You can find general information here:

https://helm.sh/docs/using_helm/#installing-helm

You'll need to take that and adapt it to your specific setup.

 

Thanks!

Highlighted
Partner
Partner

This is a bash script, not powershell.

Its meant to be running on Linux since helm is Linux only. Therefor im guessing that you run some sorrt of VM where you run helm commands? Thats where you should run the bash script to downgrade to helm to the earlier version.

Highlighted
Specialist III
Specialist III

I am trying this solution on windows machine https://github.com/tonikautto/qse-kubernetes-minikube
Highlighted
Employee
Employee

Potentially your laptop will be too small for the Minikube to function reasonably well. Try to find a machine with atleast 16 GB of RAM. Then adjust the Minikube to run on a size that matches the available resources on your machine. 

minikube start --memory 4000 --cpus=2
This error appears during Qlik package installation, when using Helm 2.14. 

Issue can be resolved by downgrading to for example Helm 2.13.1. 

choco install kubernetes-helm --version 2.13.1 --yes --force

https://github.com/tonikautto/qse-kubernetes-minikube#troubleshooting

 

 

Highlighted
Employee
Employee

@gustavgager  As a side note, Helm as a tool is not Linux only.

Highlighted
Specialist III
Specialist III

Hi Toni,
Thanks for your response.
I ran second file"1-Deploy-Minikube.ps1" with minikube start --memory 6000 --cpus=2
because my laptop has 8 GB ram only and downgraded HELM to 2.31.1 but unfortunately same error is still coming.

 

1.PNG