Qlik Community

Qlik Sense on AWS & Azure

Discussion board where members can learn more about Qlik Sense deployments on Public Cloud Infrastructures such as AWS and Azure.

Highlighted
nickhhofmann
New Contributor

Enabled SSO with AzureAD, now same user shows twice from 2 directories?

Hi all, wondering if anyone has come across this.

A client has QLIK set up, and originally they were just using their on-premise active directory to get the users in QLIk and assign them permissions etc.

We have directorysync so those domain users, show up in Azure AD. We then added the qlik enterprise app, and enabled single-sign on with SAML.

That all works fine, but the first time the user logs into QLIK from AzureAD, it creates a SECOND user in the Qlik list of users.

The first one shows User directory: DOMAIN (placeholder of local domain name)

The second one shows User directory: AZURE

This is frustrating because we assigned permissions to all the local users, and now the AZURE users don't show up until after the first time they log in to Qlik via the AzureAD app.

Is there we a way we can pre-populate all the users into the Qlik user list, but from the AZURE directory? Otherwise the first time the users log in, they have no reports/permissions/anything assigned to them

1 Reply
nicolaskaiser
New Contributor

Re: Enabled SSO with AzureAD, now same user shows twice from 2 directories?

Hi Nick,

Did you set it up with the standard SAML attribute for User Directory? In the pdf tutorial it is on [AZURE] (like in the picture attached to my post)

Did you try with your domain name as attribute?

If yes, did you manage to map the user names with the ones loaded from the LDAP or did it create doubles?

Regards

Nicolas

Regards
Nicolas